Closed Bug 1521803 Opened 9 months ago Closed 8 months ago

Title bar height is changing while dragging a tab in compact mode

Categories

(Firefox :: Tabbed Browser, defect, P2)

65 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox64 --- unaffected
firefox65 --- wontfix
firefox66 --- fix-optional
firefox67 --- fixed

People

(Reporter: waclaw66, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Tested on Windows 10 x64 (1803) with Firefox 65b12 and 66a1.

  1. Set title bar size to compact mode
  2. Open new tab
  3. Grab a tab by mouse and try to displace it

Default title bar size works ok.

Actual results:

Height of title bar is shrunk

Expected results:

Height of title bar should stay the same.

Hi Václav Nováček,

Can you please attach a screen recording of this issue? I can't reproduce it on the latest Nightly (Windows 10 x64).

Flags: needinfo?(waclaw66)
Attached image ff_titlebar.gif
Flags: needinfo?(waclaw66)

Thanks!
Reproduced on latest Nightly 66.0a1, Beta 65.0 on Windows 10 x64, Firefox Release version doesn't seem to be affected.
A small detailed to be added to STR:

  • make sure to have the tabs opened in window mode. It can't be reproduced with maximized windows.
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true

Regression test showed this...

DEBUG : Found commit message:
Bug 1356920 - Don't calculate and flush layout inside browser-tabsintitlebar.js. r=dao

Folded together the following revisions:

Bug 1356920 - Remove all toolbar layout code from browser-tabsintitlebar. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7805


Bug 1356920 - Move TabsToolbar and toolbar-menubar into the titlebar, and put the titlebar into the navigator-toolbox. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7806


Bug 1356920 - Put a spacer in the menubar to push titlebar items to the end, and stop the menu from stretching vertically. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7822


Bug 1356920 - Adjust CSS rules for new XUL document structure. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7807


Bug 1356920 - Fix placement of tracking protection icon. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7808


Bug 1356920 - Get rid of the spacer before the window caption buttons now in the TabsToolbar. r=dao

The spacer isn't necessary, since the tabbrowser-tabs node will flex to fill the available
space anyways.

Differential Revision: https://phabricator.services.mozilla.com/D7809


Bug 1356920 - Move movingtab attribute to navigator-toolbox to account for TabsToolbar not being a sibling of nav-bar anymore. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7810


Bug 1356920 - Hide the window caption buttons hbox if the native titlebar is being drawn. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7811


Bug 1356920 - Keep the macOS window caption buttons vertically centered when drag space is enabled. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7812


Bug 1356920 - Switch window caption XUL nodes from IDs to classes so that more than one can exist per doc. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7813


Bug 1356920 - Move titlebar items out into a preprocessed file to be included at build-time. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7814


Bug 1356920 - Reorganize TabsToolbar contents to force most items to the bottom of it. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D9669


Bug 1356920 - Update CSS to account for new DOM structure under TabsToolbar. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D9670


Bug 1356920 - Fix titlebar button rendering when using a lwtheme without the Windows compositor. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D9671


Bug 1356920 - Put an ordinal rule on the window caption buttons to help ensure they stay at the end of the toolbar. r=dao

This is to ensure that the buttons are placed after the post-tabs titlebar placeholder.

Differential Revision: https://phabricator.services.mozilla.com/D7815


Bug 1356920 - Stretch window caption buttons to fill vertical space on Windows 8+ when using extra drag space. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7817


Bug 1356920 - Update onViewToolbarsPopupShowing to search for toolbars that are grandchildren of the toolbox. r?jaws

Differential Revision: https://phabricator.services.mozilla.com/D7818


Bug 1356920 - Hide the titlebar items in the TabsToolbar if the menubar is being displayed. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7825


Bug 1356920 - Fix selector for titlebar. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7826


Bug 1356920 - Fix titlebar themeing on Linux. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7828


Bug 1356920 - Remove browser-tabsintitlebar layout flushes from performance test whitelist. r?florian

Differential Revision: https://phabricator.services.mozilla.com/D7829


Bug 1356920 - Fix bottom border of tabbar to account for new DOM structure. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7830


Bug 1356920 - Hide the titlebar-buttonbox-container when in fullscreen mode. r=dao

Differential Revision: https://phabricator.services.mozilla.com/D7833

Blocks: 1356920
Priority: -- → P2

Are you still seeing this? I can't seem to reproduce this in Release (65) nor Nightly.

Flags: needinfo?(waclaw66)
OS: Unspecified → Windows 10
Summary: Title bar height is changing while tab displacement → Title bar height is changing while dragging a tab in compact mode

The problem dissapeared since the last nightly (67.0a1 (2019-02-12)).
Thanks!

Flags: needinfo?(waclaw66)

Bug 1511053 probably fixed this then.

Status: NEW → RESOLVED
Closed: 8 months ago
Depends on: 1511053
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.