Closed Bug 1511215 Opened 1 year ago Closed 1 year ago

[win 10] After snapping, exiting fullscreen not respecting original window position

Categories

(Core :: Widget: Win32, defect, P3)

65 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox65 --- affected

People

(Reporter: Fanolian+BMO, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: fixed in Win10 1903, widget-next)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1502062 +++

> User Agent: Mozilla/5.0 (Windows NT 10.0; rv:64.0) Gecko/20100101
> Firefox/64.0
> 
> Steps to reproduce:
> 
> When I exit from a fullscreen video it doesn't respect the position or size
> of my browser window, resulting in tiled windows being overlapped, as well
> as firefox by itself if positioned to the edges of the screen (not snapped)
> being forced inward by about 10px on the top, bottom, and right.
> 
> --- snipped ---
> 
> Actual results:
> 
> example 1: No edge snapping used, Window positioned in the top-right corner
> of the screen manually, winds up being shoved inward. This one hurts me the
> most because on my normal setup I have the window positioned at about 65%
> width on one of my screens, with 100% of the vertical space being used.
> https://webmshare.com/VPmwz
> 
> example 2: normal window snapped to the left, with Firefox snapped to the
> right, restoring from fullscreen causes the browser window to expand by
> 10px, causing it to overflow onto the other window thus breaking tiling.
> https://webmshare.com/oQrBQ
> 
> example 2a: another issue I've encountered with the second example is that
> not only does it expand by 10px, it never stops expanding... what I mean is,
> for every time you do the transition from fullscreen the browser will gain
> 10px width every time.
> https://webmshare.com/ZQD1d

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0
Build ID: 20181129095546

Only case 1 is caused by and fixed-by-backing-out bug 1473816. As for case 2, I can still reproduce it after another (probably unrelated) snapping bug 1482920 is fixed.

Steps to reproduce:
(Please refer to the attached video. WARNING: RAPID FLASHING due to rapid fullscreen-ing)
1. Do not maximize Nightly window.
2. Snap it to the left, right, or top.
3. F11 to enter and exit fullscreen.
4. Observe the window size.


Actual result:
Nightly's window size expands. Some content are extended out of the screen.


Note:
IIRC, this may be a long standing bug that was present before Windows 10 1809(Redstone 5) update but I do not have a machine with 1803 to confirm.
Blocks: 1480928
I can confirm this is the case with Win_10 1809 (OS Build 18262.100) and FFX 65.0a1(2018-12-02).
Not reproducible on my workstation which has Win_10 1803 (OS Build 17134.407).
Status: UNCONFIRMED → NEW
Ever confirmed: true
No longer blocks: 1480928

Bug is still present as of 65.0.2 release version. Definitely does seem limited to the 1809 build.

Priority: -- → P3
Whiteboard: widget-next
Duplicate of this bug: 1541410

Just want to say this seems to be fixed with v1903 of Windows using the latest release build (67.0.1).

I just got updated to 1903 build 18362.175 too. I cannot reproduce this bug anymore.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
Whiteboard: widget-next → fixed in Win10 1903, widget-next

There were a lot of Windows DWM fixes in 1903.

I'm inclined to say this isn't worth a workaround just for 1809, it's far more minor than bug 1482920.

You need to log in before you can comment on or make changes to this bug.