Add-ons not working in Nightly

VERIFIED FIXED in Firefox 65

Status

()

defect
P1
blocker
VERIFIED FIXED
7 months ago
6 months ago

People

(Reporter: Pike, Assigned: aswan)

Tracking

({dogfood, regression})

65 Branch
mozilla65
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox63 unaffected, firefox64 unaffected, firefox65blocking verified)

Details

Attachments

(1 attachment)

Reporter

Description

7 months ago
None of my add-ons work in Nightly, on both my profiles.

I see 

Error: Unknown webextension type webextension 9 XPIProvider.jsm:1635:17

in the console.

Aswan, can this be fall-out from bug 857456?

Gecko Profiler and uBlock Origin are examples I have locally.
Flags: needinfo?(aswan)
Probably caused by a typo at https://hg.mozilla.org/mozilla-central/rev/061b97e02ede#l4.64 since I'm assuming that it should read "webextension" with one "b", and not two :-)

Updated

7 months ago
Blocks: 857456
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Nightly updates disabled.

Comment 3

7 months ago
You could just fix the typo and see whether it makes a difference.
Clearing we're missing important test coverage here too.
Severity: normal → blocker
Flags: in-testsuite?
Priority: -- → P1
(In reply to Ryan VanderMeulen [:RyanVM] from comment #4)
> Clearing we're missing important test coverage here too.

Maybe. In the past, we haven't tested these kinds of short-lived migrations much, though, so we don't really have any infrastructure for it.
Comment hidden (obsolete)

Comment 7

7 months ago
I just got hit by this after updating and restarting Nightly. But!

One of my affected extensions was Stylus, but a few minutes after restarting, Stylus was updated to a new version, and then it started working again.

I also found that by uninstalling and reinstalling a given extension, it'd also work again.

I feel like a quick workaround would be to force-update an extension (since uninstalling/reinstalling causes it to lose saved settings and such), but apparently the UI only lets me check if an update is available. Is there a way to do forced updates somehow as a temporary measure?
Has Regression Range: --- → yes
Has STR: --- → irrelevant
Keywords: dogfood
OS: Unspecified → All
Hardware: Unspecified → All
Version: Trunk → 65 Branch

Comment 8

7 months ago
I confirm the bug and @nsdragon's remark that reinstalling/upgrading an extension makes it work again.

Nightly 65.0a1 (2018-11-30) (64-bit, Ubuntu Linux 18.04.1LTS)
(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #9)
> Downgrading to latest Firefox without this issue (
> https://archive.mozilla.org/pub/firefox/nightly/2018/11/2018-11-29-21-44-05-
> mozilla-central/ ) is also next workaround.

That's not a great idea. We don't support reverse data migrations, and downgrading risks causing corruption.
Assignee

Updated

7 months ago
Assignee: nobody → aswan
Flags: needinfo?(aswan)

Comment 11

7 months ago
Well now all my addons are working again without any further intervention (just another restart of the browser). I had only reinstalled maybe 1/5th of my addons; the rest of them weren't working at all until I restarted.

Was there a nightly update in the past 45 minutes? Not sure where the right place to check the full build date is, but about:buildconfig for me points to a revision made 7 hours ago.
No, there haven't been any new Nightlies. And updates are currently frozen to the prior build rather than today's.
Assignee

Comment 14

7 months ago
For the record, there were two issues here:
1. The typo spotted in comment 1
2. The original patch migrated extensions.json but not addonStartup.json

Those files both get rewritten when there are changes to the set of active addons, so updating or uninstalling an existing addon, or installing a new one, would cause new correct versions of those files to be written and everything would work properly after a browser restart.

With the patch from the try run above, both issues above should be fixed and both files should be properly migrated without any further user action.

Comment 15

7 months ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #13)
> For those who can reproduce, can you try of of the builds below to see if
> things work better? Usual caveats apply about backing up your profile, etc.
> 
> Linux64:
> https://queue.taskcluster.net/v1/task/ZfUb7ydXTYOMfrJg-7hMnw/runs/0/
> artifacts/public/build/target.tar.bz2

This build fixed it for me, all my addons are back in my toolbar and active.
Using Ubuntu Linux 18.04.1LTS.

Comment 17

7 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/bb2815518fc7
Fix migration from bug 857456. r=kmag, r=zombie, a=RyanVM

Comment 18

7 months ago
Pushed by aswan@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/b1446de2dd13
Follow-up: Don't blow up on empty addonStartup.json r=zombie a=RyanVM
Assignee

Updated

7 months ago
Duplicate of this bug: 1511445
New nightlies are currently being built and updates will be re-enabled once they're finished. Builds with Build ID of 20181130191449 or newer should contain the fix.
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

Comment 21

7 months ago
Reddit Enhancemnt Suite, HTTPS Everywhere and Decentraleyes are still not working, maybe even more but uBlock seems to be working fine.

Comment 22

7 months ago
Forgot to mention I'm using build 20181130200939.
Assignee

Comment 23

7 months ago
(In reply to Jules A from comment #21)
> Reddit Enhancemnt Suite, HTTPS Everywhere and Decentraleyes are still not
> working, maybe even more but uBlock seems to be working fine.

If you're still having problems, please open a separate bug and include more detail about exactly what isn't working.
(In reply to Kris Maglione [:kmag] from comment #10)
> (In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see
> your comment/reply/question/etc.) from comment #9)
> > Downgrading to latest Firefox without this issue (
> > https://archive.mozilla.org/pub/firefox/nightly/2018/11/2018-11-29-21-44-05-
> > mozilla-central/ ) is also next workaround.
> 
> That's not a great idea. We don't support reverse data migrations, and
> downgrading risks causing corruption.

True, but it thankfully worked in my case without any negative effects and profile wasn't damaged, but like always I had backup close at hand.

(In reply to Jules A from comment #21)
> Reddit Enhancemnt Suite, HTTPS Everywhere and Decentraleyes are still not
> working, maybe even more but uBlock seems to be working fine.

In my case Decentraleyes working fine, as other extensions like:
- CanvasBlocker 0.5.5
- Cookie AutoDelete 2.2.0
- CSS Exfil Protection 1.0.11
- Decentraleyes 2.0.8
- Disable HTML5 Autoplay 2018.10.3
- Don't touch my tabs! (rel=noopener) 2.1
- Don't track me Google 4.21
- Download Star 2.0.2
- Firefox Pioneer 1.0
- uBlock Origin 1.17.3.105
working fine, so I'm confirming that bug is fixed in latest Nightly and I'm marking this bug as VERIFIED. Thank you very much. \o/
Status: RESOLVED → VERIFIED
QA Contact: Virtual

Comment 25

7 months ago
Oddly enough resetting extensions.databaseSchema pref fixed it for me.
You need to log in before you can comment on or make changes to this bug.