Closed Bug 15117 Opened 21 years ago Closed 20 years ago

Start creating XML entity content objects.

Categories

(Core :: XML, defect, P3)

All
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 15118

People

(Reporter: nisheeth_mozilla, Assigned: nisheeth_mozilla)

Details

(Keywords: helpwanted)

The code for the XML entity content object is available in the mozilla codebase.
We need to investigate whether we want to start using it to manufacture entities
and populate the DOM with them.

The things to do here are to examine what the behavior of MS IE 5.0 is and to
get some feedback from the net about whether we should expand entities
internally or expose them via the DOM.  I'm keeping this bug within the beta
time frame so that we resolve this issue as soon as possible.

CCing vidur, David, and Ian for feedback.
Status: NEW → ASSIGNED
Target Milestone: M12
Whiteboard: HELP WANTED
If this is done, Normalize needs to be fixed to normalize within entity
references (if that's the right thing to do).  See bug 9779.
Move non-PDT+ bugs to M13...
Moving non beta-stoppers to M16...
Keywords: helpwanted
Whiteboard: HELP WANTED
IE's XML parser does not expand entity references when it is used in 
non-validating mode.   

One other thing that became clear to me is that entity and entity reference 
objects are two separate objects in the DOM.  We definitely need to create 
entity objects for each entity declaration we see in an XML document.  We have 
more flexibility in creating entity reference objects because we only need to 
create them if the XML parser does not expand entity references internally.
Moving bugs out by one milestone...
Target Milestone: M16 → M17
Bring in to M16 for now...
Target Milestone: M17 → M16
bug 15118 describes the work we need to do to create the doctype object and 
populate the doctype.entities NamedNodeMap.

I'm marking this bug as a duplicate of that bug.

*** This bug has been marked as a duplicate of 15118 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.