The default bug view has changed. See this FAQ.

expat doesn't send notifications for doctype.notations and doctype.entities

RESOLVED INVALID

Status

()

Core
XML
P3
normal
RESOLVED INVALID
18 years ago
3 years ago

People

(Reporter: Nisheeth Ranjan, Unassigned)

Tracking

({dom1})

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P5])

(Reporter)

Description

18 years ago
The code for CDATA Section, DOCTYPE, NamedNodeMap, Notation, Processing
Instruction objects is in the tree.  We need to start using it to create these
content objects and populate the DOM with them...

I'm currently scheduling this work for post beta.  If time permits, I'll try to
do this for beta.
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Reporter)

Updated

18 years ago
Blocks: 9075
(Reporter)

Comment 1

18 years ago
*** Bug 11694 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

17 years ago
Moving bugs out by one milestone...
Target Milestone: M15 → M16
(Reporter)

Comment 3

17 years ago
Updating summary.

We need to pass up entity and notation declarations from expat to the XML 
content sink.  Currently, only the doctype declaration is passed up.  

The sink, then, needs to create the doctype object and populate the 
"doctype.entities" and "doctype.notations" NamedNodeMaps with Entity and 
Notation nodes respectively.

Adding heikki and jst to the cc list to keep them in the loop.
Summary: Start using currently unused XML content objects. → Create Doctype objects in the content sink.
(Reporter)

Comment 4

17 years ago
*** Bug 15117 has been marked as a duplicate of this bug. ***
*** Bug 41293 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

17 years ago
We should try and get this in for beta 3.  Marking nsbeta3, and setting target 
milestone to M18...
Summary: Create Doctype objects in the content sink. → Create Doctype objects in the XML content sink.
Target Milestone: M16 → M18

Comment 7

17 years ago
Since this is necessary for DOM Level 1 compatibility, I'd like to see if in for 
beta 2. The fix itself is simple and low risk, but at this point we are 
incompabtible with IE5. Nominating nsbeta2.
Keywords: nsbeta2

Comment 8

17 years ago
nsbeta2+ until 6/22
Whiteboard: [nsbeta2+] [6/22]
(Reporter)

Comment 9

17 years ago
Vidur has the fix for this in his tree.  Re-assigning to him so that he can mark 
this fixed when he checks it in.
Assignee: nisheeth → vidur
Status: ASSIGNED → NEW

Comment 10

17 years ago
We now process the Doctype notification (the nsbeta2+ part, checked in on 
6/16/2000), but expat still doesn't pass us notations and entities. Removing the 
nsbeta2 designation and passing the bug back to Nisheeth. We should consider 
futuring this one. 
Assignee: vidur → nisheeth
Keywords: nsbeta2
Summary: Create Doctype objects in the XML content sink. → expat doesn't send notifications for doctype.notations and doctype.entities
Whiteboard: [nsbeta2+] [6/22]
(Reporter)

Comment 11

17 years ago
Marking nsbeta3 for now...  This might not be difficult to do and this is a DOM 
1 compliance issue.  If it turns out that we are completely overloaded with beta 
3 stuff, we can consider futuring this.
Status: NEW → ASSIGNED
Keywords: nsbeta3
Keywords: correctness

Comment 12

17 years ago
...and that's how it turned out. nsbeta3-, ->future
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
(Reporter)

Updated

17 years ago
Blocks: 9850

Updated

17 years ago
QA Contact: chrisd → petersen
Whiteboard: [nsbeta3-] → [Hixie-P5]

Updated

15 years ago
Keywords: helpwanted

Updated

15 years ago
Keywords: dom1

Updated

15 years ago
QA Contact: petersen → rakeshmishra

Updated

14 years ago
QA Contact: rakeshmishra → ashishbhatt

Comment 13

14 years ago
*** Bug 215257 has been marked as a duplicate of this bug. ***

Updated

13 years ago
OS: Windows NT → All
Assignee: nisheeth_mozilla → nobody
Flags: wanted1.9.2?
QA Contact: ashshbhatt → xml
Status: ASSIGNED → NEW

Updated

6 years ago
Depends on: 604595
Flags: wanted1.9.2?
Keywords: helpwanted
We dropped support for those attributes.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.