Closed Bug 1512013 Opened 6 years ago Closed 10 months ago

Cursor jumps to the begining of the awesomebar after tab swap

Categories

(Firefox :: Address Bar, defect, P3)

defect

Tracking

()

RESOLVED FIXED
116 Branch
Tracking Status
firefox-esr60 --- unaffected
firefox-esr102 --- wontfix
firefox-esr115 --- fixed
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox115 --- fixed
firefox116 --- fixed

People

(Reporter: cfogel, Assigned: daisuke)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image awesomebarCursor.gif
[Affected versions]:
- 63.0.3, 64.0b14, 65.0a1 (2018-12-03) 

[Affected platforms]:
- Win10x64, macOS 10.11.6, Ubuntu 18.04

[Steps to reproduce]:
1. Launch Firefox;
2. Open 2 tabs with different websites;
3. Click inside the address bar and move the cursor to the (right-side) end of the links;
4. Click to change the tabs;

[Expected result]:
- Cursor remains in the same position;

[Actual result]:
- cursor is placed at the beginning of the links;

[Regression range]:
- bug 1423220; versions considered good had the adress-text selected after the tab swap so it might be something else;

[Additional notes]:
- attached recording with the issue;
Hey Mike, mind confirming if it's not something else?
Thank you!
Flags: needinfo?(mconley)
This may also be a consequence of bug 1395508, where we move the selection to the beginning to ensure the domain stays visible.

We do this in a couple code points:
https://searchfox.org/mozilla-central/rev/2e5e28f518524f8af5b158ddb605022b6a2d68cf/browser/base/content/browser.js#2678
https://searchfox.org/mozilla-central/rev/2e5e28f518524f8af5b158ddb605022b6a2d68cf/browser/base/content/urlbarBindings.xml#898
Should be investigated whether it's one of these causing the issue, and what we can do to prevent it.

Overall it seems like an annoyance anyway, not breaking a very common workflow.
Priority: -- → P3
Since this is triaged and has a priority set, marking this fix-optional to remove it from regression triage. 
Happy to still take a patch in nightly.
Flags: needinfo?(mconley)
Regressed by: 1423220
Severity: normal → S4
Has Regression Range: --- → yes

Bug 1836051 fixed this

Status: NEW → RESOLVED
Closed: 10 months ago
Depends on: 1836051
Resolution: --- → FIXED
Assignee: nobody → daisuke
Target Milestone: --- → 116 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: