Closed Bug 1512730 Opened Last year Closed Last year

Update webrender to 41c12cabc42228dda6a2d2628c9b24df9aca66b4 (WR PR #3398)

Categories

(Core :: Graphics: WebRender, defect, P3)

65 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox65 --- fixed
firefox66 --- fixed

People

(Reporter: kats, Assigned: kvark)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1512624 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/wrupdater/blob/master/try-latest-webrender.sh
Alias: wr-future-update
Assignee: nobody → dmalyshau
Summary: Future webrender update bug → Update webrender to 41c12cabc42228dda6a2d2628c9b24df9aca66b4 (WR PR #3398)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d24ac329431
Update webrender to commit 41c12cabc42228dda6a2d2628c9b24df9aca66b4 (WR PR #3398). r=kats
https://hg.mozilla.org/mozilla-central/rev/5d24ac329431
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Comment on attachment 9030363 [details]
Bug 1512730 - Update webrender to commit 41c12cabc42228dda6a2d2628c9b24df9aca66b4 (WR PR #3398). r?kats

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: For users selected to use WebRender (Windows + certain NVIDIA hardware), they will have their GPU crash periodically while browsing. This will downgrade them to basic compositing resulting in worse performance and denies us telemetry results for WebRender for the duration of the session.

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It is not risky because the change is small, well understood, and limited as an internal detail to WebRender.

String changes made/needed:
Attachment #9030363 - Flags: approval-mozilla-beta?
Crash Signature: [@ core::option::expect_failed | core::iter::{{impl}}::next<T>] [@ core::option::expect_failed | <core::iter::Map<I, F> as core::iter::iterator::Iterator>::next]
Keywords: crash
Comment on attachment 9030363 [details]
Bug 1512730 - Update webrender to commit 41c12cabc42228dda6a2d2628c9b24df9aca66b4 (WR PR #3398). r?kats

[Triage Comment]
Fixes GPU crashes for users running with WebRender enabled. Approved for 65.0b5.
Attachment #9030363 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1517039
Type: enhancement → defect
You need to log in before you can comment on or make changes to this bug.