[Socket-process] Do not init the complete XPCOM

RESOLVED FIXED in Firefox 66

Status

()

defect
P2
normal
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: dragana, Assigned: dragana)

Tracking

(Blocks 2 bugs)

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Fission Milestone:M1, firefox66 fixed)

Details

(Whiteboard: [necko-triaged])

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Description

6 months ago
No description provided.
Assignee

Updated

6 months ago
Blocks: socket-proc
Assignee

Updated

6 months ago
Assignee: nobody → dd.mozilla
Status: NEW → ASSIGNED
Priority: -- → P2
Whiteboard: [necko-triaged]
Assignee

Comment 4

6 months ago
Bug 1471535 is interesting to take a look. They needed to do some work to make the rdd process (the MediaDataDecoder process) running.
Duplicate of this bug: 1511318
Assignee

Comment 6

6 months ago
Posted file Use mininal XPCOM. (obsolete) —
Assignee

Updated

6 months ago
Attachment #9031187 - Attachment is obsolete: true
Assignee

Updated

5 months ago
Keywords: checkin-needed

We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpuqasvo\npatching file dom/power/PowerManagerService.cpp\nHunk #2 FAILED at 177\n1 out of 2 hunks FAILED -- saving rejects to file dom/power/PowerManagerService.cpp.rej\nabort: patch failed to apply', '')

Flags: needinfo?(dd.mozilla)
Keywords: checkin-needed
Assignee

Comment 11

5 months ago

(In reply to Cosmin Sabou [:CosminS] from comment #10)

We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again. (255, 'applying /tmp/tmpuqasvo\npatching file dom/power/PowerManagerService.cpp\nHunk #2 FAILED at 177\n1 out of 2 hunks FAILED -- saving rejects to file dom/power/PowerManagerService.cpp.rej\nabort: patch failed to apply', '')

Thanks. I have rebased the patch.

Flags: needinfo?(dd.mozilla)
Keywords: checkin-needed

Comment 12

5 months ago

Pushed by aiakab@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8d4aa37d7137
Use the minimal XPCOM for the socket process.r=froydnj

Keywords: checkin-needed

Comment 13

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

Updated

4 months ago
Fission Milestone: --- → M1
You need to log in before you can comment on or make changes to this bug.