Closed Bug 1513062 Opened 2 years ago Closed 2 years ago

Crash in webrender::render_task::RenderTask::new_picture on https://www.magicleap.com/magic-leap-one

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1505934
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- disabled
firefox65 --- disabled
firefox66 --- fixed

People

(Reporter: jan, Unassigned)

References

(Blocks 2 open bugs, )

Details

(4 keywords)

Crash Data

(hgallagher from bug 1493917 comment 23)
> Hi, I found this bug report through about:support, everytime I try to scroll down on https://www.magicleap.com/magic-leap-one Nightly crashes on me. 
> 
> https://crash-stats.mozilla.com/report/index/f68a21e9-994c-442c-b6b7-16fd00181210 is one of them.

RUST_BACKTRACE=1 mozregression --repo mozilla-inbound --good 2018-09-01 --bad 285eb0ebe26f --pref gfx.webrender.all:true -B debug -a https://www.magicleap.com/magic-leap-one
> 10:32.03 INFO: [GFX1-]: Attempting to create a render task of size 123041x146701
> 10:32.03 INFO: ERROR 2018-12-10T20:30:05Z: webrender::render_task: Attempting to create a render task of size 123041x146701
> 10:32.03 INFO: thread 'WRRenderBackend#1' panicked at 'explicit panic', gfx/webrender/src/render_task.rs:44:9
> [...]
> 11:24.66 INFO: Last good revision: e414fcdabb7209d3ac6a0052f4c0c8c8c89ab35d
> 11:24.66 INFO: First bad revision: 5bfe272aa1a2e80b562e245b48346e9c5aa4acee
> 11:24.66 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e414fcdabb7209d3ac6a0052f4c0c8c8c89ab35d&tochange=5bfe272aa1a2e80b562e245b48346e9c5aa4acee

> 5bfe272aa1a2	Jeff Muizelaar — Bug 1490242. Adjust reftests for 3d transfrom changes
> 8c80d5351916	Jeff Muizelaar — Bug 1490242. Update webrender to 04d63e7d73b9661d9eb934a0933c8f9751a9a3db
bp-0a302774-b1f5-45b6-9f37-98eb00181210
Crash Signature: [@ webrender::render_task::RenderTask::new_picture ] → [@ webrender::render_task::RenderTask::new_picture ] [@ ?MOZ_CrashOOL@@YAXPEBDH0@Z.llvm.17152006278596193988 ]
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Severity: normal → critical
Keywords: reproducible
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1505934
You need to log in before you can comment on or make changes to this bug.