Mozmill failure on 2018-12-11: 8 failing tests

RESOLVED FIXED in Thunderbird 66.0

Status

defect
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: jorgk, Assigned: darktrojan)

Tracking

Trunk
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago
TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment-events.js | test-attachment-events.js::test_attachments_removed_on_multiple
TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment.js | test-attachment.js::test_selected_attachments_are_cleared
TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment.js | test-attachment.js::test_select_all_attachments_key
TEST-UNEXPECTED-FAIL | [snip]/mozmill/attachment/test-attachment.js | test-attachment.js::test_attachments_compose_menu
TEST-UNEXPECTED-FAIL | [snip]/mozmill/cloudfile/test-cloudfile-notifications.js | test-cloudfile-notifications.js::test_offer_then_upload_notifications
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-attachment.js | test-attachment.js::test_delete_attachments
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-attachment.js | test-attachment.js::test_rename_attachment
TEST-UNEXPECTED-FAIL | [snip]/mozmill/composition/test-attachment.js | test-attachment.js::test_open_attachment
TEST-UNEXPECTED-FAIL | [snip]/mozmill/eventDialog/testEventDialog.js | testEventDialog.js::testEventDialog
TEST-UNEXPECTED-FAIL | [snip]/mozmill/eventDialog/testEventDialogModificationPrompt.js | testEventDialogModificationPrompt.js::testEventDialogModificationPrompt
TEST-UNEXPECTED-FAIL | [snip]/mozmill/eventDialog/testUTF8.js | testUTF8.js::testUTF8

M-C last good: 68151063d1c63ce445d67aa743a018d7f6
M-C first bad: 13f891b92db19ea8ec85ef329eff7a793c
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=68151063d1c63ce445d67aa743a018d7f6&tochange=13f891b92db19ea8ec85ef329eff7a793c

Log https://taskcluster-artifacts.net/QD8xnfIkTB-ln__QNbaSKw/0/public/logs/live_backing.log says:
INFO -  SUMMARY-UNEXPECTED-FAIL | test-attachment-events.js | test-attachment-events.js::test_attachments_removed_on_multiple
INFO -    EXCEPTION: a != b: '3' != '1'.

INFO -  SUMMARY-UNEXPECTED-FAIL | test-attachment.js | test-attachment.js::test_selected_attachments_are_cleared
INFO -    EXCEPTION: el is undefined; can't access its "getBoundingClientRect" property

and more. This looks like bug 1492326, but I could be wrong.

Some Calendar tests also failing. Geoff, can you fix this while we sleep?
Flags: needinfo?(geoff)
Assignee

Comment 1

5 months ago
Okay, we need to change the tag names from attachmentlist back to richlistbox and from attachmentitem to richlistitem.
Flags: needinfo?(geoff)
Assignee

Updated

5 months ago
Keywords: leave-open

Comment 2

5 months ago
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/a41cffeea0d9
Temporarily disable 8 failing tests caused by bug 1492326; rs=bustage-fix

Comment 3

5 months ago
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/fa11fa323710
Backed out changeset a41cffeea0d9 ; rs=backout
https://hg.mozilla.org/comm-central/rev/713a7a7a6cdb
Replace <attachmentlist> with <richlistbox> and replace <attachmentitem> with <richlistitem>; rs=bustage-fix
Assignee

Comment 4

5 months ago
This has already landed, so it doesn't matter who reviews it as long as somebody does.
Assignee: nobody → geoff
Status: NEW → ASSIGNED
Attachment #9030404 - Flags: review?(jorgk)
Attachment #9030404 - Flags: review?(acelists)
Reporter

Comment 5

5 months ago
What about the three failing Calendar tests which still fail on Mac only? Different issue? New bug?
TEST-UNEXPECTED-FAIL | /Users/cltbld/tasks/task_1544510175/build/tests/mozmill/eventDialog/testEventDialog.js | testEventDialog.js::testEventDialog
TEST-UNEXPECTED-FAIL | /Users/cltbld/tasks/task_1544510175/build/tests/mozmill/eventDialog/testEventDialogModificationPrompt.js | testEventDialogModificationPrompt.js::testEventDialogModificationPrompt
TEST-UNEXPECTED-FAIL | /Users/cltbld/tasks/task_1544510175/build/tests/mozmill/eventDialog/testUTF8.js | testUTF8.js::testUTF8
Flags: needinfo?(geoff)
Reporter

Comment 6

5 months ago
OK, let's move the Calendar failures to a new bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(geoff)
Keywords: leave-open
Resolution: --- → FIXED
Summary: Mozmill failure on 2018-12-11: 11 failing tests → Mozmill failure on 2018-12-11: 8 failing tests
Target Milestone: --- → Thunderbird 66.0
Version: 60 → Trunk
Reporter

Comment 7

5 months ago
Comment on attachment 9030404 [details] [diff] [review]
1513110-attachment-elements-1.diff

I'll be lazy here and leave the XUL stuff to Aceman who also knows much better.
Attachment #9030404 - Flags: review?(jorgk)

Comment 8

5 months ago
Comment on attachment 9030404 [details] [diff] [review]
1513110-attachment-elements-1.diff

Review of attachment 9030404 [details] [diff] [review]:
-----------------------------------------------------------------

And why is this needed? What did bug 1492326 change?
Attachment #9030404 - Flags: review?(acelists) → review+
Assignee

Comment 9

5 months ago
At https://hg.mozilla.org/mozilla-central/rev/0c7a54d4cc42#l7.1 the code now explicitly looks for elements by name instead of interface. Which seems like a bad idea in my opinion, but I'm also not really a fan of subclassing elements with a new name.
You need to log in before you can comment on or make changes to this bug.