Closed Bug 1513242 Opened 11 months ago Closed 11 months ago

Crash in java.lang.UnsatisfiedLinkError: at org.mozilla.gecko.GeckoSystemStateListener.onDeviceChanged(Native Method)

Categories

(GeckoView :: General, defect, critical)

65 Branch
defect
Not set
critical

Tracking

(geckoview64+ fixed, firefox64 wontfix, firefox65 verified, firefox66 verified)

RESOLVED FIXED
mozilla66
Tracking Status
geckoview64 + fixed
firefox64 --- wontfix
firefox65 --- verified
firefox66 --- verified

People

(Reporter: calixte, Assigned: snorp)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, topcrash)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is
report bp-13f96bbe-a703-4605-9f4a-cb2760181205.
=============================================================

Java stack trace:

java.lang.UnsatisfiedLinkError
	at org.mozilla.gecko.GeckoSystemStateListener.onDeviceChanged(Native Method)
	at org.mozilla.gecko.GeckoSystemStateListener.access$000(GeckoSystemStateListener.java:22)
	at org.mozilla.gecko.GeckoSystemStateListener$1.onChange(GeckoSystemStateListener.java:55)
	at android.database.ContentObserver.onChange(ContentObserver.java:130)
	at android.database.ContentObserver.onChange(ContentObserver.java:145)
	at android.database.ContentObserver$NotificationRunnable.run(ContentObserver.java:216)
	at android.os.Handler.handleCallback(Handler.java:790)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6501)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:438)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:807)

There are 35 crashes (from 30 installations) in 64.0b15 with buildid 20181203203319. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1505897.

[1] https://hg.mozilla.org/releases/mozilla-beta/rev?node=766dc4a5e8f0
Flags: needinfo?(snorp)
Sometimes Gecko isn't running yet when we get our first notifications.
Flags: needinfo?(snorp)
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9413770742e0
Queue native calls in GeckoSystemStateListener r=geckoview-reviewers,esawin
https://hg.mozilla.org/mozilla-central/rev/9413770742e0
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
James, should we uplift this fix to 65 Beta and the 64 relbranch? I see crash reports from Fennec 64.0b15, but I don't see any from Focus and GV 64 yet.

https://crash-stats.mozilla.com/signature/?signature=java.lang.UnsatisfiedLinkError%3A+at+org.mozilla.gecko.GeckoSystemStateListener.onDeviceChanged(Native+Method%29
Assignee: nobody → snorp
Flags: needinfo?(snorp)
We should just uplift this to 65.
Flags: needinfo?(snorp)
We may want to keep this on the Fennec 64 radar for now until we have a better idea of what the crash frequency looks like post-release.
Go ahead with that Beta approval request whenever you're comfortable doing so.
Flags: needinfo?(snorp)
Comment on attachment 9030531 [details]
Bug 1513242 - Queue native calls in GeckoSystemStateListener

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1505897

User impact if declined: Crashes

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce: We don't have specific STR.

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Pretty mundane patch to simply queue a native call like we do everywhere else in GeckoView.

String changes made/needed: None
Attachment #9030531 - Flags: approval-mozilla-beta?
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #5)
> We should just uplift this to 65.

OK. 64=wontfix.
Comment on attachment 9030531 [details]
Bug 1513242 - Queue native calls in GeckoSystemStateListener

[Triage Comment]
Fixes a Fennec crash, approved for 65.0b5.
Attachment #9030531 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(snorp)
#5 crash on 64.0.1 so far.  No crash since the fix in 65 or 66, so marking verified.
Product: Firefox for Android → GeckoView
Version: Firefox 65 → 65 Branch
Target Milestone: Firefox 66 → mozilla66

Comment on attachment 9030531 [details]
Bug 1513242 - Queue native calls in GeckoSystemStateListener

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: N/A

User impact if declined: Crashes

Is this code covered by automated tests?: Unknown

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce:

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): It has already been uplifted to 65 without any problems.

String changes made/needed:

Attachment #9030531 - Flags: approval-mozilla-release?

This is showing up in the top 5 crashes in the play store for Focus (which is using 64), so requesting uplift there.

Comment on attachment 9030531 [details]
Bug 1513242 - Queue native calls in GeckoSystemStateListener

We're not planning any more Fennec 64 releases, so I think a GV64 uplift is what you meant here? Anyway, I'll approve it that way :)

Attachment #9030531 - Flags: approval-mozilla-release? → approval-mozilla-geckoview64+
You need to log in before you can comment on or make changes to this bug.