Closed Bug 1513349 Opened Last year Closed Last year

Editing a tree cell causes other cells in the row to become invisible

Categories

(Toolkit :: Themes, defect)

65 Branch
Unspecified
Windows 10
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 + verified
firefox66 + verified

People

(Reporter: alice0775, Assigned: ntim)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
[Tracking Requested - why for this release]: UI becomes broken

See attached screenshot

Steps To Reproduce:
1. Remember password
2. Open about:preferences#privacy
3. Click on [Saved Login] button
4. Click on [Show Password] Button
5. Double click on a user name or a password field to edit it

Actual Results:
Site name and other column becomes invisible.

Expected Results:
Should be visible(readable)


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f643580be3cb0f73a5f175fa366730ab16f6a42b&tochange=9a4db52c22c20c1d872c1eaac1bafd4b6b1cca66

Regressed by: 9a4db52c22c2	Tim Nguyen — Bug 1508142 - Remove remains of tree cell-based selection code. r=bzbarsky,bgrins
:ntim
Your patch seems to cause the regression, can you please look into this?
Flags: needinfo?(ntim.bugs)
This change [0] regressed this.

Reintroducing support for currentColumn + the active selector would be overkill IMO.

I believe these two rules can just be removed altogether, since the .tree-input overlays the edited cell anyway (hiding the text underneath).

[0]: https://hg.mozilla.org/integration/autoland/rev/9a4db52c22c2#l23.12
Flags: needinfo?(ntim.bugs)
Summary: When I am editing username and password in password manager, site name and other column becomes invisible. → Editing a tree cell causes other cells in the row to become invisible
Duplicate of this bug: 1513329
No longer depends on: 1513329
Attachment #9030553 - Attachment description: Bug 1513349 - Remove now erronous tree cell editing styles. r=dao → Bug 1513349 - Remove now erroneous tree cell editing styles. r=dao
Component: Password Manager → Themes
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/af677b06f934
Remove now erroneous tree cell editing styles. r=dao
Assignee: nobody → ntim.bugs
Comment on attachment 9030553 [details]
Bug 1513349 - Remove now erronous tree cell editing styles. r=dao

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1508142

User impact if declined: See comment 0 and bug 1513329 comment 0

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: Yes

If yes, steps to reproduce: See comment 0 and bug 1513329 comment 0

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): small CSS removal

String changes made/needed: no
Attachment #9030553 - Attachment description: Bug 1513349 - Remove now erroneous tree cell editing styles. r=dao → Bug 1513349 - Remove now erronous tree cell editing styles. r=dao
Attachment #9030553 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/af677b06f934
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Flags: qe-verify+
Comment on attachment 9030553 [details]
Bug 1513349 - Remove now erronous tree cell editing styles. r=dao

[Triage Comment]
Removes some unnecessary and erroneous tree cell editing rules. Approved for 65.0b5.
Attachment #9030553 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reproduced the issue on 65.0b4.
Verified as fixed with 65.0b5 build from taskcluster and Nightly 66.0a1 on Windows 10x64, macOS 10.14 and Ubuntu 14.04.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.