Resize events break run-to-completion

RESOLVED DUPLICATE of bug 1044074

Status

defect
P2
normal
RESOLVED DUPLICATE of bug 1044074
5 months ago
15 days ago

People

(Reporter: bhackett, Assigned: bhackett)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 months ago
Posted patch patchSplinter Review
Resize events can fire if the debugger is paused, breaking run-to-completion.  The attached patch fixes this, by not firing resize events while the associated document has events suppressed.  If one or more resizes are suppressed, a single resize is fired after the document unsuppresses events.
Attachment #9030926 - Flags: review?(bugs)
Priority: -- → P2
Comment on attachment 9030926 [details] [diff] [review]
patch

a test would be nice.
Attachment #9030926 - Flags: review?(bugs) → review+
Comment on attachment 9030926 [details] [diff] [review]
patch

Oh, wait, this is against the spec. Resize needs to fire during Tick().
Attachment #9030926 - Flags: review+ → review-
Assignee

Comment 3

5 months ago
The fix in bug 1044074 took care of both resize and scroll events.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044074
You need to log in before you can comment on or make changes to this bug.