Import patch for ICU-20302

RESOLVED FIXED in Firefox 65

Status

()

defect
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: anba, Assigned: anba)

Tracking

Trunk
mozilla66
Points:
---

Firefox Tracking Flags

(firefox64 unaffected, firefox65+ fixed, firefox66+ fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
https://unicode-org.atlassian.net/browse/ICU-20302 (<https://github.com/unicode-org/icu/pull/315>) fixes a time zone detection issue on Windows 7. We should import the patch in our local ICU copy.

Hat tip to Jeff Genovy for pinging us in the ICU bug report!
(Assignee)

Comment 1

5 months ago
This issue only affects ICU 63, so I guess we want to backport the patch to Beta, given that Beta uses ICU 63 (bug 1499026).
Blocks: 1499026
(Assignee)

Comment 2

5 months ago
Imported the two PRs via
```
  wget https://github.com/unicode-org/icu/pull/315.patch -O bug-1513934-timezone-detection-win7-part1.diff
  wget https://github.com/unicode-org/icu/pull/318.patch -O bug-1513934-timezone-detection-win7-part2.diff
```

and then reimported the ICU-63 maintenance branch. That means we also get <https://github.com/unicode-org/icu/pull/283> to fix a performance regression in UnicodeSet <https://unicode-org.atlassian.net/browse/ICU-20250>.
Attachment #9031432 - Flags: review?(jwalden+bmo)
Waldo, can you please prioritize this review as it's a patch targeting Fx65 and we're already halfway through the Beta cycle?
Flags: needinfo?(jwalden)

Updated

5 months ago
Attachment #9031432 - Flags: review?(jwalden) → review+
Comment on attachment 9031432 [details] [diff] [review]
bug1513934.patch

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Potential problems with time zone detection on Windows 7 -- exactly what problems, seems to depend on the state of the program and other things.

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Medium

Why is the change risky/not risky? (and alternatives if risky): This is importing fixes from upstream, so that probably mitigates the risk a bit.  But this does touch a bit of code (mostly for the fixes that are *not* time zone-related, that were already on the maintenance branch), so it's not the targeted patch it could be.

String changes made/needed: N/A
Flags: needinfo?(jwalden)
Attachment #9031432 - Flags: approval-mozilla-beta?

Comment 5

5 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6ac79113d538
Import ICU patch to fix possible time zone misdetection on Windows 7. r=Waldo

Comment 6

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6ac79113d538
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Comment on attachment 9031432 [details] [diff] [review]
bug1513934.patch

[Triage Comment]
Fixes problems with time zone detection on Windows 7 caused by the most recent ICU update. Approved for 65.0b8.
Attachment #9031432 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.