Closed Bug 1514000 Opened 2 years ago Closed 1 year ago

Suppress duplicated changes in bug history made at the same time mainly due to mid-air collisions

Categories

(bugzilla.mozilla.org :: General, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: marco, Assigned: kohei.yoshino)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
{
          "when": "2015-10-19T22:30:11Z",
          "who": "giles@thaumas.net",
          "changes": [
            {
              "removed": "--",
              "added": "P2",
              "field_name": "priority"
            },
            {
              "removed": "",
              "added": "giles@thaumas.net",
              "field_name": "cc"
            }
          ]
        },
        {
          "when": "2015-10-19T22:30:11Z",
          "who": "ajones@mozilla.com",
          "changes": [
            {
              "removed": "--",
              "added": "P2",
              "field_name": "priority"
            }
          ]
        },
Something similar happened in bug 1245724, with the sec-bounty? -> sec-bounty+ change.
And in bug 1264595, with the priority field.
Component: API → General

Those are probably mid-air collisions. Maybe the second change can be hidden from the history both in the UI and API.

Duplicate of this bug: 1516172
Summary: Priority changed twice in bug 1215089 → Suppress duplicated changes in bug history made on the same time mainly due to mid-air collisions
Duplicate of this bug: 1514003
Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED
Summary: Suppress duplicated changes in bug history made on the same time mainly due to mid-air collisions → Suppress duplicated changes in bug history made at the same time mainly due to mid-air collisions
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Regressions: 1556320
You need to log in before you can comment on or make changes to this bug.