Closed Bug 1514018 Opened 2 years ago Closed 2 years ago

Create a hero unit section component for Activity Stream experiment functionality

Categories

(Firefox :: New Tab Page, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox66 --- fixed

People

(Reporter: thecount, Assigned: gsuntop)

References

Details

(Keywords: github-merged)

Attachments

(2 files)

We need this to be something we can turn on and off, and can land in nightly 66 without breaking any existing functionality.

It needs designs still, but I can attach wire frames.
Attached image hero.png
Blocks: 1513353
Severity: normal → enhancement
Iteration: --- → 66.1 - Dec 10-23
Priority: -- → P2
Blocks: 1512725
Iteration: 66.1 - Dec 10-23 → 66.2 - Dec 24 - Jan 6
Assignee: nobody → gsuntop
Iteration: 66.2 - Dec 24 - Jan 6 → 66.3 - Jan 7 - 20

Landed progress in https://github.com/mozilla/activity-stream/pull/4644

  • enforce image aspect ratios
  • wire up links & add interaction states (active/focus/hover)
  • generally tighten up styling
  • set count of cards based on remote layout definition
  • enforce character counts
Blocks: 1519303
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/915ef9df72e0f4de333aa41a728f049d4be43f60
Bug 1514018 - Hero component refinement (WIP) (#4653)

- enforce image aspect ratios
- wire up links & add interaction states (active/focus/hover)
- generally tighten up styling
- set count of cards based on remote layout definition
- enforce character counts
Status: RESOLVED → REOPENED
Keywords: github-merged
Resolution: FIXED → ---
Target Milestone: Firefox 66 → ---
Blocks: 1520324
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

Hi,

Any updates on QA steps.

Thanks,
Brahmini

Flags: needinfo?(sdowne)

QA Steps

Set browser.newtabpage.activity-stream.discoverystream.config to {"enabled":true,"layout_endpoint":"https://getpocket.com/v3/newtab/layout?version=1&consumer_key=40249-e88c401e1b1f2242d9e441c4&layout_variant=dev-test-1"}

Open new tab and look at Hero component to verify

  • enforced image aspect ratios (see Figma)
  • wired up links & add interaction states (active/focus/hover) (see Figma)
  • set count of cards based on remote layout definition (this layout has 3)
  • enforced character counts (see Figma)
Flags: needinfo?(sdowne)

Item title isn't highlighted when hovered anywhere within Hero section

Tracking issue here : https://bugzilla.mozilla.org/show_bug.cgi?id=1521643

Severity: enhancement → normal
Flags: needinfo?(sdowne)
Flags: needinfo?(sdowne) → needinfo?(gsuntop)

QA Results :

Tested on :

FF Nightly version : 66.0a1 (2019-01-20)

OS : Mac and Windows 10 Pro

Closing as verified as the issue is being tracked separately bug 1521643

However, the entire experiment should be re-tested once the issue is fixed.

Status: RESOLVED → VERIFIED
Flags: needinfo?(gsuntop)
Severity: normal → enhancement
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.