"this folder is being processed" dialog BAD actor

VERIFIED DUPLICATE of bug 101584

Status

MailNews Core
Networking: POP
--
major
VERIFIED DUPLICATE of bug 101584
16 years ago
10 years ago

People

(Reporter: crawdad, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Whenever the mail/news window is open, I frequently get an error dialog which
states something to the effect that:
"This folder is being processed, please wait to get messages till finished."
This is REALLY REALLY annoying.

The dialog and the window pop to the surface, then disappear when the dialoog is
dismissed.

This is extremely and needlessly disruptive, to the point of near unusabilty.
If I'm in the middle of doing something, this causes keystrokes to disappear
into the ether, somethimes with ungood resluts.
And if I have mail and news both open, or 2 different groups or servers, I have
no idea what/where is being processed.

And, "processed" how, to what end?


win2kpro, 1.1alpha 20020611
See bug 91731.  I'm not sure why this is occuring more frequently for you, but
the fact that it comes up at all isn't a bug, I don't think.

Over to Networking:POP
Assignee: sspitzer → naving
Component: Networking: News → Networking: POP
QA Contact: stephend → sheelar
(Reporter)

Comment 2

16 years ago
The is NO reason for this dialog to just appear from nowhere and stay there till
manually dismissed.

It happens frequently for me because I have my "check for new" set to a shortish
interval, but regardless: 
It is WRONG for this dialog to popup unprovoked and wait till it is manually
dismissed.

pls make this go away!

Why should this dialog appear at all?

If you wanna see how bad it is, set "check for new" to 2 or 3 minutes, thenm try
to read and surf and comnpose... You'll spenf a lot of time typing into the
ether, and this is WRONG!
(Reporter)

Comment 3

16 years ago
I would like to add that this dialog does NOT incessantly appear when I say "NO"
to the "Compress folders" dialog...

Perhaps this belongs in database or back-end component?

Comment 4

16 years ago
I see this behaviour too (frequently, on average  15 minutes?, but NOT
regularly) - I get the "This folder is being processed.." dialog).
I'm using 1.1 Alpha.  Only started seeing this since moving from 1.0.
I agree that this isnt acceptable behaviour - although I see the need for
locking whilst a compress is in progress, surely a "scheduled" mail download
should just wait for the compress to finish rather than throw an error?

Its difficult for me to identify which folders are involved as I have 3 IMAP
accounts, one POP, and three news servers. If we are to see this error from time
to time, perhaps a message something like "Folder xxx is currently locked,
unable to download mail at present" would be better.

I'd hazard a guess that somehow one of my folders is being incorrectly left
locked..  I do have a hefty 100Mb + IMAP mailbox here,  so perhaps the compress
process slips up there; BUT there is evidence that the POP mailbox is involved -
a manual Get Messages for that account has thrown up the dialog a few times.

Some settings that might be relevant:
IMAP account #1: check for New every 1 minute
IMAP account #2, #3: doesnt check
POP:  check every 30 mins, and download
NNTP accounts don't check.

I have Compact when.. set to 1000kb.


 



Comment 5

16 years ago
the fact that I can't do anything with my mail until I completely close all
mozilla windows (mail and browser) makes this pretty frustrating. I can't delete
messages, I can't read other messages..

Comment 6

16 years ago
changing the state since we do show this dialog when the compaction is in
progress and also when new mail message arrives at the start up.  

Reporter,
So the request here is not to throw the dialog?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
This bug is marked a dup of 101584

*** This bug has been marked as a duplicate of 101584 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.