Closed Bug 1514669 Opened 2 years ago Closed 2 years ago

Prepare for m-c removal of nsISAXXMLReader in XMPP

Categories

(Chat Core :: XMPP, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1518552

People

(Reporter: hsivonen, Unassigned)

References

Details

(In reply to Henri Sivonen (:hsivonen) from comment #0)
> Bug 1447707 will remove nsISAXXMLReader from m-c.
> 
> https://searchfox.org/comm-central/source/chat/protocols/xmpp/xmpp-xml.jsm
> uses it.

Is there another supported way to parse an incoming XML stream?
Flags: needinfo?(hsivonen)
We don't have any other JS-exposed way to parse XML in a SAX-like way that doesn't involve DOM nodes. An <iframe> and I *think* XHR let you see the DOM tree as it's being built, though. Parsing via XHR and removing the old DOM nodes once you've seen them might work.

One option is to move nsISAXXMLReader, etc., to c-c.
Flags: needinfo?(hsivonen)
From the m-c perspective, the removal is now ready to land, but I could wait until the second week of January or so before landing it, since it seems potentially impolite to break c-c at this time of year. Are you planning to import the code to c-c, and if so, should this bug and bug 1514666 be collapsed into one?
Flags: needinfo?(florian)

The Sax parser has now been removed as announced for the second week of January. So should we fork it?

The SAX parser was forked to comm-central in bug 1518552; closing as a duplicate, but thanks for the initial heads up Henri.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(florian)
Resolution: --- → DUPLICATE
Duplicate of bug: 1518552
Blocks: 1647252
You need to log in before you can comment on or make changes to this bug.