Fork saxparser to common/ after its removal in bug 1447707

RESOLVED FIXED in Thunderbird 66.0

Status

enhancement
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: jorgk, Unassigned)

Tracking

Trunk
Thunderbird 66.0

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 months ago
No description provided.
Reporter

Updated

5 months ago
Summary: Fork saxparser to common after it's removal in bug 1447707 → Fork saxparser to common/ after its removal in bug 1447707
Reporter

Comment 1

5 months ago

I'll push the removed code to C-C now.

Keywords: leave-open

Comment 2

5 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/837f28a0a4f2
Fork saxparser to common/ after its removal in bug 1447707. rs=bustage-fix
Reporter

Comment 3

5 months ago

I'll see whether I can get the tests going.

Comment 4

5 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/53e0e1023adc
Follow-up: Remove unneeded test_sanitizer.js. rs=bustage-fix DONTBUILD
Reporter

Comment 5

5 months ago

Geoff, could you please take a look at the linting problems this introduced. And if you could get the test going, that would be a bonus.

Flags: needinfo?(geoff)
Reporter

Comment 6

5 months ago

Test already works:
https://taskcluster-artifacts.net/LvgPOcyFRcyIUcoiUXSuyA/0/public/logs/live_backing.log
TEST-PASS | comm/common/saxparser/test/unit/test_parser.js

Also the one we don't need since it's still in M-C worked:
TEST-PASS | comm/common/saxparser/test/unit/test_sanitizer.js

So all that's left is fixing the linting errors:
c:\mozilla-source\comm-central\comm\common\saxparser\test\unit.eslintrc.js
6:4 error Missing trailing comma. comma-dangle (eslint)

c:\mozilla-source\comm-central\comm\common\saxparser\test\unit\test_parser.js
24:20 error Unexpected named method 'startDocument'. func-names (eslint)
27:18 error Unexpected named method 'endDocument'. func-names (eslint)
etc.

I can of course put // eslint-disable-line func-names onto those.

Reporter

Updated

5 months ago
Flags: needinfo?(geoff)
Keywords: leave-open
Reporter

Updated

5 months ago
Target Milestone: --- → Thunderbird 66.0

Comment 7

5 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/715f97e4c9ae
Follow-up: Fix linting errors. rs=bustage-fix DONTBUILD

Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1514669
You need to log in before you can comment on or make changes to this bug.