Closed Bug 1515086 Opened 11 months ago Closed 11 months ago

Crash in js::frontend::ParseNodeVisitor<T>::visit

Categories

(Core :: JavaScript Engine, defect, critical)

Unspecified
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: djc, Unassigned)

References

()

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-9afcb356-2947-49fe-8e06-71c9e0181218.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so js::frontend::ParseNodeVisitor<FoldVisitor>::visit js/src/frontend/ParseNode.h:645
1 libxul.so js::frontend::ParseNodeVisitor<FoldVisitor>::visit js/src/frontend/ParseNode.h:892
2 libxul.so js::frontend::ParseNodeVisitor<FoldVisitor>::visit js/src/frontend/ParseNode.h
3 libxul.so js::frontend::ParseNodeVisitor<FoldVisitor>::visit js/src/frontend/ParseNode.h:1202
4 libxul.so js::frontend::ParseNodeVisitor<FoldVisitor>::visit js/src/frontend/ParseNode.h
5 libxul.so js::frontend::FoldConstants js/src/frontend/FoldConstants.cpp:1442
6 libxul.so js::frontend::GeneralParser<js::frontend::FullParseHandler, char16_t>::objectLiteral js/src/frontend/Parser.cpp:9830
7 libxul.so js::frontend::GeneralParser<js::frontend::FullParseHandler, char16_t>::primaryExpr js/src/frontend/Parser.cpp:10167
8 libxul.so js::frontend::GeneralParser<js::frontend::FullParseHandler, char16_t>::memberExpr js/src/frontend/Parser.cpp:8737
9 libxul.so js::frontend::GeneralParser<js::frontend::FullParseHandler, char16_t>::unaryExpr js/src/frontend/Parser.cpp:8531

=============================================================
Likely regression from Bug 1513040 - but it appears it was backed out so the next build should no longer have the crash.
I thought Android got twice-daily updates too? The Play Store tells me there's been no update since 17h ago.
We were able to reproduce this with build from 12-18 and we can confirm that Nightly is no longer crashing when visiting Twitter using the build from 12-19.
Blocks: 1513040
Work for me, too, now.
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.