Nested event loops do not suspend scroll events (Visual Viewport)

REOPENED
Unassigned

Status

defect
P3
normal
REOPENED
5 months ago
16 days ago

People

(Reporter: JanH, Unassigned)

Tracking

(Blocks 1 bug)

66 Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [devtools-platform])

Reporter

Description

5 months ago
+++ This bug was initially created as a clone of Bug #1044074 +++

I guess the Visual Viewport scroll/resize events (bug 1478776) might require the same treatment?
Reporter

Updated

5 months ago
OS: Windows 8.1 → Unspecified
Hardware: x86_64 → Unspecified
Version: 31 Branch → 66 Branch
Priority: -- → P2
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1044074
Reporter

Comment 2

4 months ago

Erm, the visual viewport event handling was developed in parallel to bug 1044074, so when both patches landed within a few days of each other, neither took account of the event handling changes caused by the other patch.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Brian, what do you think?

Flags: needinfo?(bhackett1024)

I think we'll need to fix this eventually but I don't think this needs to be done soon. It looks like the W3C viewport API is still a draft and from bug 1478776 is not enabled by default yet. Run to completion bugs are annoying to users but won't break the debugger and given the design of the devtools server (spinning up a normal event loop when the debugger is paused) these bugs will be hard to eliminate entirely.

Flags: needinfo?(bhackett1024)
Priority: P2 → P3
You need to log in before you can comment on or make changes to this bug.