Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: rcrespo, Assigned: dp)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
umm today's appruner 0928 .. win32 crashed on startup
attached is the stack trace
APPRUNNER caused an invalid page fault in
module XPCOM.DLL at 0137:60acf82e.
Registers:
EAX=00000000 CS=0137 EIP=60acf82e EFLGS=00010246
EBX=00004400 SS=013f ESP=0063f57c EBP=0063f5b4
ECX=00000000 DS=013f ESI=0063f5a0 FS=39cf
EDX=c2646620 ES=013f EDI=00004400 GS=0000
Bytes at CS:EIP:
66 83 24 41 00 eb 09 8b 46 10 8b 0e 80 24 08 00
Stack dump:
60af8894 009dd4d4 60acf87c 0063f5a0 00004400 60af8894 00000400 009dd4d4 0063f5fc
00000000 00008000 00000001 00000001 00000000 0063f5d4 60acf92d

just says homepage is http://www.mozilla.org
and then crashes

need any more info email me

Updated

20 years ago
Summary: crash on startup → Win32: crash on startup

Updated

20 years ago
QA Contact: beppe → paulmac
Assignee

Comment 1

20 years ago
Paulmac, can I get more input on this. Can we reproduce this inhouse.

Comment 2

20 years ago
rcrespo, does this happen every time at start-up? If so, try a few things:

Find the file named component.reg in your apprunner dir and rename it then rerun
Also please e-mail me the file.

If that doesn't work, delete the file mozregistry.dat in c:\windows and also
your entire \users50 directory.

dp, I have seen other start-up crashes in xpcom.dll, I'll search around for it,
but we can't reproduce this in-house right now.

Thanks.

Comment 3

20 years ago
looks like bug 13151 and bug 14015 might be related

Comment 4

20 years ago
Had the same problem with the 99.10.01 build but worked around by
renaming/deleting mozregistry.dat file.  Hope this helps
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 5

20 years ago
Ah. That must be seth's changes to mozregistry requiring deletion. I understand
now.

Darrel, thanks for the data point.

Updated

20 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.