Apprunner crashes with xpcom.dll at startup with no output

VERIFIED WORKSFORME

Status

()

defect
P1
major
VERIFIED WORKSFORME
20 years ago
19 years ago

People

(Reporter: jmellen, Assigned: neeti)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

20 years ago
Overview Description:

                    Steps to Reproduce:
                    1)Download mozilla_win32.zip
                    2)Extract files
                    3)Run apprunner.exe

                    Actual Results:

apprunner.exe causes an invalid page fault with modual xpcom.dll. No text is
shown on console.

                    Expected Results:
apprunner init

                    Build Date & Platform Bug Found:
Build from September 4, 1999. Windows 98 on AMD K62-3D 450. 64mb ram.

                    Additional Builds and Platforms Tested On:
none
                    Additional Information:
I tried this from a build on August 13 and had the same problem. I have a
feeling it is my machine but if not then this needs to be checked.

*******************
APPRUNNER caused an invalid page fault in
module XPCOM.DLL at 015f:60b24746.
Registers:
EAX=3a6c6572 CS=015f EIP=60b24746 EFLGS=00010206
EBX=007a1570 SS=0167 ESP=0063f688 EBP=0063f6d4
ECX=007a1584 DS=0167 ESI=007a1584 FS=74af
EDX=007a156c ES=0167 EDI=007a02f0 GS=0000
Bytes at CS:EIP:
ff 50 04 8b 06 85 c0 74 06 8b 08 50 ff 51 08 89
Stack dump:
007a02f0 007a1580 10002108 60b372b6 007a02f0 00000000 00764310 0077e480 60b38546
100020f8 007a02f0 00764030 00000000 007a1760 60b43ec8 f0a8af16
*********************

Comment 1

20 years ago
*** Bug 13152 has been marked as a duplicate of this bug. ***
Reporter

Updated

20 years ago
Severity: major → normal
Reporter

Comment 2

20 years ago
I just tried build from September 10. It has the same problem. This is clearly
something wrong with my machine (along with many other things). But, this could
still be a problem in the future. I'm changing it from major to normal though.

Updated

20 years ago
Severity: normal → major
Component: XPCOM → Profile Manager
Priority: P3 → P1
Summary: apprunner.exe crashes with xpcom.dll on startup → Apprunner crashes at installation if lacking pre-existing registry file

Comment 3

20 years ago
Before downloading and installing a nightly build, I typically delete the
\Windows\MozRegistry.dat file and the \Users50 directories.
All builds lately downloaded by this one have crashed at the following juncture:
Files extracted, Apprunner executed, Profile created ("Finish" clicked) - Crash.
The 1999091310 build is the latest to so topple. If, however, the
\Windows\MozRegistry.dat file is left intact, the beast arises with it's normal
fearfulness.
[Resetting to Major, and assigning P1: Crasher]

XPCOM.DLL, however?

APPRUNNER caused an invalid page fault in
module RAPTORHTML.DLL at 023f:60431604.
Registers:
EAX=008bf880 CS=023f EIP=60431604 EFLGS=00010246
EBX=00000020 SS=0247 ESP=0063f190 EBP=0063f1a4
ECX=00000054 DS=0247 ESI=008bf2f0 FS=441f
EDX=0063f19c ES=0247 EDI=00000000 GS=0000
Bytes at CS:EIP:
ff 51 58 8b 45 f8 85 c0 74 2a 8b 08 8d 55 fc 52
Stack dump:
008bf880 0063f19c 008bf480 008bf2f0 008bf2f0 0063f1dc 60431074 011e7430 60792f05
011e7430 008bf2f0 00000001 007a2ef0 607927f7 011e7430 006a8ab4

Final gasps of debug window:

Entered Create Profile RoutineEntered Start AppRunner Routine
Run AppRunner with profile -> mozProfile <-
Created nsToolkitCore
Profile Manager : Profile Wizard and Manager activites : End
failed to get sidebar_pref
 move to 10 10
QIing for pref interface

Updated

20 years ago
Assignee: dp → racham
Is this you ?

Comment 5

20 years ago
dp,
It looks like it's coming from prefs.
Meanwhile, I will trace thru.

Comment 6

20 years ago
Adding the debug stack trace...

dp, who is working on prefs now...?

nsPresContext::PreferenceChanged(const char * 0x0201e940) line 252 + 19 bytes
PrefChangedCallback(const char * 0x0201e940, void * 0x01a2ee20) line 55
pref_DoCallback(const char * 0x0201e940) line 2313 + 17 bytes
pref_HashPref(const char * 0x0201e940, PrefValue {...}, int 32, int 0) line 1878
+ 9 bytes
PREF_SetDefaultCharPref(const char * 0x0201e940, const char * 0x0201e8c0) line
813 + 17 bytes
nsPref::SetDefaultCharPref(nsPref * const 0x00aa63b0, const char * 0x0201e940,
const char * 0x0201e8c0) line 654 + 13 bytes
XPTC_InvokeByIndex(nsISupports * 0x00aa63b0, unsigned int 38, unsigned int 2,
nsXPTCVariant * 0x0012e63c) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x01f8e080,
nsXPCWrappedNative * 0x0201f140, const XPCNativeMemberDescriptor * 0x00e5d700,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 2, long *
0x00e1d018, long * 0x0012e85c) line 661 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x01f8e080, JSObject * 0x01d30638, unsigned
int 2, long * 0x00e1d018, long * 0x0012e85c) line 170 + 34 bytes
js_Invoke(JSContext * 0x01f8e080, unsigned int 2, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x01f8e080, long * 0x0012f08c) line 2228 + 15 bytes
js_Invoke(JSContext * 0x01f8e080, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x01f8e080, long * 0x0012f878) line 2228 + 15 bytes
js_Invoke(JSContext * 0x01f8e080, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x01f8e080, JSObject * 0x00dd4a70, long 15267752,
unsigned int 1, long * 0x0012f994, long * 0x0012f9fc) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x01f8e080, JSObject * 0x00dd4a70, long
15267752, unsigned int 1, long * 0x0012f994, long * 0x0012f9fc) line 2662 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x018262d0) line 110 + 43 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc80, nsIDOMEvent * * 0x0012fb5c, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 991 + 21 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x01f8e244,
nsIPresContext & {...}, nsEvent * 0x0012fc80, nsIDOMEvent * * 0x0012fb5c,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 2848
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x01fcbe44, nsIDocumentLoader *
0x01fca040, nsIChannel * 0x020409d0, unsigned int 0, nsIDocumentLoaderObserver *
0x01fcbe44) line 3367 + 34 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x01fca040, unsigned
int 0) line 1103
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x01fca044, nsIChannel *
0x024ea490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 974
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x01fcbdd0, nsIChannel *
0x024ea490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 570 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x024ea49c, nsIChannel *
0x024ea490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 838
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x024ecf60) line
269
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x024ecf64) line 144 + 12 bytes
PL_HandleEvent(PLEvent * 0x024ecf64) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00aa6ab0) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00830552, unsigned int 49301, unsigned int 0,
long 11168432) line 938 + 9 bytes
USER32! 77e71268()
00aa6ab0()

Comment 7

20 years ago
Adding troy to the cc list. He worked on nsPresContext.cpp. His input will be
useful too.

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE

Comment 8

20 years ago
*** This bug has been marked as a duplicate of 13780 ***
Reporter

Updated

20 years ago
Status: RESOLVED → REOPENED
Component: Profile Manager → XPCOM
Reporter

Comment 9

20 years ago
I left town so I did not catch this soon enough.

Crysgem:
This is not the same problem as you are talking about.

This does not even create a profile window before crashing. Please read my file
again. It doesn't look like a dup of 13780. If it is, then my mistake.

Updated

20 years ago
Resolution: DUPLICATE → ---

Comment 10

20 years ago
Clearing DUPLICATE resolution due to reopen.
Reporter

Updated

20 years ago
Summary: Apprunner crashes at installation if lacking pre-existing registry file → Apprunner crashes with xpcom.dll at startup with no output
Reporter

Comment 11

20 years ago
I tested some of the other programs in the /bin directory and got these results:

These crashed with the same error:
viewer.exe
mailboxtest.exe
proxyeventtest.exe (xpcom32.dll)
proxytest
regfactory.exe
regxpcom.dll
smtptest.exe
stringbundletest.exe
testfactory.exe
testxpc.exe
xpcshell.exe

These had a link error with xpcom.dll:
testbuffers.exe
scribble.exe
nettest.exe

Since the dll crashes first thing, I think that there is a problem with the init
code. If I get the chance I will take a look at it.

Updated

20 years ago
Assignee: racham → troy
Status: REOPENED → NEW

Comment 12

20 years ago
Crashing in nsPresContext.cpp [252 mShell->GetRootFrame(&rootFrame);]. Stack
trace included in one of the updates. I have enabled dump statements to see if
the crash is happening before the profile manager activities are finished.
The crash occurs after the profile activites are done. Reassining the bug to
troy. Adding neeti (for preferences) to the cc list.

Updated

20 years ago
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME

Comment 13

20 years ago
Viewer is running just fine for me. If people see a problem in apprunner, then
re-open this bug and assign it someone on apprunner or make a new bug

Just because it crashes in layout code doesn't mean it has anything to do with
layout. There may be memory corruptions occuring, for example. The
PreferenceChanged() code is not the problem...

Updated

20 years ago
Status: RESOLVED → REOPENED

Comment 14

20 years ago
Reopening the bug to solve the crash in apprunner. Assigning it to XPCOM
Module (dp@netscape.com).

Updated

20 years ago
Assignee: troy → dp
Status: REOPENED → NEW

Updated

20 years ago
Resolution: WORKSFORME → ---

Comment 15

20 years ago
Clearing WORKSFORME resolution due to reopen.

Updated

20 years ago
Assignee: dp → neeti
The stack trace looks like pref. Neeti can you take a look.
Assignee

Comment 17

20 years ago
The stack trace showing prefs is not for this bug which is bug 13780. This bug
is not a duplicate of 13780. jmellon, can you specify the exact steps you did to
reproduce this bug, because when I try to run apprunner, the first time it
crashes is when I have deleted my mozregistry.dat and it is creating a new
profile in the following method nsPresContext::PreferenceChanged(const char *
0x0201e940. But this bug 13780.  So when you crash, is your stack trace the
some?
Reporter

Comment 18

20 years ago
I do just whaat I said earlier. No files are deleted. I use the Win98 unzip and
it replaces the files in c:\mozilla-win32. Persoanly I think the problem is my
computer but if others come up with the same trace then who knows.

I say it is not 13780 because the profile wizard doesn't run. There was also no
mozregistry.dat in c:\windows. Do all the other programs mentioned involve the
prefs system?

My stack trace is the same.
Assignee

Comment 19

20 years ago
If there is no mozregistry.dat, apprunner will always bring up the profile
wizard first. Looks like, you crash even before the profile wizard come up.
Paul, could you test if apprunner crashes before the profile wizard comes up.

I cannot make it crash before the profile wizard come up.
I tried it with the 09/16/99 build.
1)Download mozilla_win32.zip
2)Extract files
3)Run apprunner.exe

Apprunner crashes after the profile wizard comes up the first time(bug 13780).
The second time, it runs fine.
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

20 years ago
QA Contact: beppe → paulmac

Comment 20

20 years ago
Sorry, just saw the note. No, I can't reproduce this, but look at bug 14015 and
bug 15167, possibly related.

Comment 21

20 years ago
*** Bug 15928 has been marked as a duplicate of this bug. ***

Comment 22

20 years ago
I have the same problem with Milestone 10 (AMD K6-2-300 3DNOW, Windows 98).
Apprunner crashes with:
APPRUNNER verursachte einen Fehler durch eine ungültige Seite
in Modul XPCOM.DLL bei 015f:60ad1510.
Register:
EAX=00000000 CS=015f EIP=60ad1510 EFLGS=00010216
EBX=006e8810 SS=0167 ESP=0063eeb8 EBP=0063efc0
ECX=000000a1 DS=0167 ESI=0063eff0 FS=5927
EDX=81725ebc ES=0167 EDI=0063efec GS=0000
Bytes bei CS:EIP:
80 38 00 74 08 50 8b ce e8 1e fa ff ff 5e c9 c3
Stapelwerte:
0063eff0 00000100 0000010c bff7b9b6 8174f74c 0000010c 780012b1 0000003f 00000100
0000010c bff7b9b6 0000003f 0063ef84 011c9c20 bff7b9b6 8174f74c

Comment 23

20 years ago
After having deleted "c:\windows\mozregistry.dat" , mozilla comes up without any
problems.
Neeti could you mark this bug fixed or worksforme, if this is mozregistry.dat
begin the wrong format.

Comment 25

20 years ago
Should we still be crashing with a corrupted registry? Shouldn't we have
something more graceful?
Yes. I wish. That would be bug on selmer/seth.
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME

Comment 27

19 years ago
sorry for the spam, changing QA contact.
QA Contact: paulmac → leger

Comment 28

19 years ago
Old bug...there is no longer and apprunner, mozilla is ok.  Marking Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.