Legacy add-ons "Find replacement" button has wrong text color

VERIFIED FIXED in Firefox 65

Status

()

defect
P3
normal
VERIFIED FIXED
5 months ago
3 months ago

People

(Reporter: ntim, Assigned: dao)

Tracking

({regression})

unspecified
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 fixed, firefox66 verified)

Details

Attachments

(2 attachments)

Reporter

Description

5 months ago
Similar to bug 1509629, but less visible as this page rarely appears (it still does as of today though)
Reporter

Updated

5 months ago
Blocks: 1473922
Reporter

Comment 1

5 months ago
Dão, can you please look into this ?
Flags: needinfo?(dao+bmo)
Keywords: regression
Assignee

Updated

5 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Priority: -- → P3

Comment 4

5 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/636318254d8f
Drop custom styling for "Find replacement" button for legacy addons. r=aswan

Comment 5

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Flags: qe-verify+
Assignee

Comment 6

5 months ago

Comment on attachment 9034663 [details]
Bug 1516770 - Drop custom styling for "Find replacement" button for legacy addons. r=aswan

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: bug 1473922

User impact if declined: see comment 0

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce:

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): trivial fix

String changes made/needed:

Attachment #9034663 - Flags: approval-mozilla-beta?

Comment on attachment 9034663 [details]
Bug 1516770 - Drop custom styling for "Find replacement" button for legacy addons. r=aswan

[Triage Comment]
Minor CSS fix-up. Approved for 65.0b10.

Attachment #9034663 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I cannot reproduce the issue, due to the fact that I cannot install a deprecated legacy addon in Fx65 or Fx66.

  • I have tried to install "website_city_country_info-1.0.1.4-fx" (which is a legacy addon) in Fx 53 and then update Fx to the latest version, but the addon is removed after the update.
  • I have also tried to open the profile created in Fx53 with the addon installed in Fx66, but the addon does not show up in the extension list.

Could you please provide a legacy addon with which to test this issue and maybe a way to force install it in Fx66/Fx65?
Either that or in a worst case scenario confirm that the Fix was applied in Fx65.0b10?

Flags: needinfo?(ntim.bugs)
Reporter

Updated

4 months ago
Flags: needinfo?(ntim.bugs) → needinfo?(aswan)

(In reply to Cristian Baica [:cbaica], Release Desktop QA from comment #9)

  • I have tried to install "website_city_country_info-1.0.1.4-fx" (which is a legacy addon) in Fx 53 and then update Fx to the latest version, but the addon is removed after the update.

I'm not familiar with website_city_country_info but that should not happen, the extension should appear in the "Legacy Extensions" pane of about:addons, instead of the "Extensions" pane.

In any case, I have a profile with a legacy extension installed and I can confirm that this is fixed in the 2019-01-12 Nightly.

Status: RESOLVED → VERIFIED
Flags: needinfo?(aswan)

If it's not too much to ask, could you also verify the fix on the latest beta build? Just so we can set the appropriate flags for that branch as well.

Flags: needinfo?(aswan)
Flags: qe-verify+

Sorry this fell through the cracks. I don't have a profile handy for testing this but given thatn 65 is already on release, I assume even if we found a problem there, we wouldn't bother to uplift a fix.

Flags: needinfo?(aswan)
You need to log in before you can comment on or make changes to this bug.