Closed Bug 1517160 Opened 1 year ago Closed 1 year ago

Favicon missing for internal pages (about:home, about:firefox, etc.)

Categories

(Firefox for Android :: Theme and Visual Design, defect, P2)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 66
Tracking Status
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 + verified

People

(Reporter: JanH, Assigned: snorp)

References

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.
Flags: needinfo?(snorp)
Anthony, can you help find an owner for this issue? Thanks!
Flags: needinfo?(alam)
This was simply broken by the changes in bug 1510711, so I don't think this needs any UX input.
Flags: needinfo?(alam)

Petru, is this something your team can take a look at or do you think you might need help from the geckoview team?

Flags: needinfo?(petru.lingurar)
Assignee: nobody → vlad.baicu

Removing my NI as Vlad is now the assignee.

Flags: needinfo?(petru.lingurar)

I investigated the favicons but everything seems fine. Jan, is there something else left to do here ?

Flags: needinfo?(jh+bugzilla)

Compare the favicon of about:firefox in the tabs tray in Nightly and Beta - it should be a tiny Firefox logo, but on Nightly it's currently missing and replaced by a "?" because Snorp broke it.

Flags: needinfo?(jh+bugzilla)

Yeah I'll take a look.

Flags: needinfo?(snorp)

Assigning snorp to the bug as this was in my work queue but he already put up a patch for the issue.

Assignee: vlad.baicu → snorp

Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ba5964567a6
Use correct icon path for internal about pages r=geckoview-reviewers,esawin#geckoview-reviewers

Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
https://hg.mozilla.org/projects/cedar/rev/8ba5964567a64f6a09b4de8ea4f8e8d151958f00
Bug 1517160 - Use correct icon path for internal about pages r=geckoview-reviewers,esawin#geckoview-reviewers

Verified as fixed on the latest Nightly 66.0a1 (2019-01-28), with HTC 10 (Android 8.0)
Thank you!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.