Closed Bug 1517729 Opened 11 months ago Closed 11 months ago

Fix generating content process crash minidumps on Windows AArch64

Categories

(Toolkit :: Crash Reporting, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gsvelto, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1513284 +++

As per my investigation in bug 1513284 the exception handler for child processes is being installed correctly and the out-of-process crash generation machinery seems to be working properly but when a content processes crash no minidump is generated. This is either caused by the exception handler not being invoked correctly (which is what I suspect to be happening) or something else equally obscure.
Depends on: 1517730

As it turns out content crash reports have always been generated correctly. The reason why I couldn't get any was that I was using the crashfirefox-intentionally tool to crash the content process and the tool did not work properly on ARM64. I've patched it up and now I can reliably crash all types of AArch64 processes. With the tool fixed I can submit content crash reports just fine and some other users also did in the past few days.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.