Closed Bug 1518113 Opened 8 months ago Closed 8 months ago

Use the "application" role for Preferences in Firefox 65

Categories

(Core :: Disability Access APIs, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox65 --- fixed
firefox66 --- wontfix

People

(Reporter: Paolo, Assigned: Paolo)

References

Details

Attachments

(1 file)

We need to revert the Preferences document to the "application" role on Beta to prevent bug 1514687 from happening, to give us more time for testing a patch that fixes the underlying issue in Nightly.
Jamie, can you confirm that this prevents bug 1514687 from happening?
Flags: needinfo?(jteh)

It'd be more correct to say that it makes it less likely that most users will encounter this, since a user can still force treatment as a document and thus encounter this problem. But... yes, this restores the previous behaviour.

Flags: needinfo?(jteh)

Comment on attachment 9034695 [details]
Bug 1518113 - Use the "application" role for Preferences in Firefox 65. r=Jamie

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1429940

User impact if declined: Bug 1514687

Is this code covered by automated tests?: Yes

Has the fix been verified in Nightly?: Yes

Needs manual test from QE?: No

If yes, steps to reproduce:

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): This restores the previous behavior.

String changes made/needed:

Attachment #9034695 - Flags: approval-mozilla-beta?

Comment on attachment 9034695 [details]
Bug 1518113 - Use the "application" role for Preferences in Firefox 65. r=Jamie

[Triage Comment]
Reverts us back to previous known-good behavior. Approved for 65.0b10.

Attachment #9034695 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.