Closed Bug 1518202 Opened 9 months ago Closed 7 months ago

Add cross-process proxies for Location

Categories

(Core :: DOM: Core & HTML, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Fission Milestone M1
Tracking Status
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: peterv, Assigned: peterv)

References

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
Attachment #9034769 - Attachment is obsolete: true
Fission Milestone: --- → M1
Whiteboard: [1/30] need to address review comments; not actively working on this
Whiteboard: [1/30] need to address review comments; not actively working on this → [2/14] need to address review comments; not actively working on this
Priority: P2 → P1
Whiteboard: [2/14] need to address review comments; not actively working on this → [2/25] addressing review comments
Whiteboard: [2/25] addressing review comments → [2/28] waiting for bz review
Fission Milestone: M1 → M2
Whiteboard: [2/28] waiting for bz review → [2/28] ready to land
Pushed by pvanderbeken@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/71fd1aa112d8
Add cross-process proxies for Location. r=bzbarsky
https://hg.mozilla.org/integration/autoland/rev/58405fa4f0d9
Make RemoteObjectProxies add the edge to the native object to the CC. r=bzbarsky
Fission Milestone: M2 → M1
Whiteboard: [2/28] ready to land
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1516350
Blocks: 1532994
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.