Closed Bug 1518403 Opened 8 months ago Closed 8 months ago

Make IsCurrent reflect the animation's playback rate

Categories

(Core :: DOM: Animation, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: birtles, Assigned: birtles)

References

()

Details

Attachments

(3 files)

Based on whatever spec changes come out of:

https://github.com/w3c/csswg-drafts/issues/3193

As per the following spec change:

  https://github.com/w3c/csswg-drafts/commit/4ec1deb76ab7a6d6cf4cd6818dc63387ea595884

Spec issue:

  https://github.com/w3c/csswg-drafts/issues/3193

Of the added test cases, only the last one, "Returns reversed animations yet to
reach their active phase" fails without this code change. The others pass
because the animation is finished at that point but I added them for consistency
with the previous tests.

Try run with zero playback rate animations not considered "is current" for before/after phase:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4d0d6905f340bfe61e2384eee3af8eb30641fff8

Blocks: 1330498

And adding a test case that we run these animations on the compositor (i.e. that bug 1330498 is fixed):
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d3bb3f0ba7c5b44bec57cf8691d580e20539cb78

(Thanks for fixing typos there.)

No longer blocks: 1330498
Duplicate of this bug: 1330498
Depends on: 1518982
Pushed by bbirtles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8fa3111ea8e
Make "is current" depend on the direction of the associated animation's playback rate; r=hiro
https://hg.mozilla.org/integration/autoland/rev/052892f1cbd1
Make IsCurrent return false for animations with playback rate == 0 that are in before/active phase; r=hiro
https://hg.mozilla.org/integration/autoland/rev/2f2b4d6aabeb
Add test that animations with a negative playback rate are sent to the compositor even in the delay phase; r=hiro
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/14793 for changes under testing/web-platform/tests
You need to log in before you can comment on or make changes to this bug.