Status

defect
VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: naving, Assigned: naving)

Tracking

({intl})

Trunk
mozilla1.0.1
x86
Windows 2000
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 RTM] [ETA 06/20])

Attachments

(3 attachments)

This is a copy of bugscape bug 15175. created to get drivers approval for 1_0 branch

tested 05-01 JA
Win XP Pro. JA

1. Launch Mail&Newsgroups
2. Create a account for Netscape Webmail
3. Expand Netscape Webmail account
   There are "Draft" , "Sent" folder names in English.
   "Inbox", "Trash" are tlanslated.
   If it comes from server, ignore this. 
   Please refer attachment.



------- Additional Comment #1 From kasumi 2002-05-07 11:18 -------

Created an attachment (id=5947)
screen capture



------- Additional Comment #2 From Ying-Lin Xia 2002-05-07 12:08 -------

We can not control those WebMail folder names, they come from the server. And 
the current webmail is English version, we can assume it will be fine once the 
Japanese version webmail is avaliable. Mark as INVALID.



------- Additional Comment #3 From ji@netscape.com 2002-05-07 12:17 -------

But why are Inbox and Trash translated?



------- Additional Comment #4 From Ying-Lin Xia 2002-05-07 12:28 -------

Good question! Reopening...



------- Additional Comment #5 From Ying-Lin Xia 2002-05-08 19:14 -------

But I don't think it's showstopper for jab1...



------- Additional Comment #6 From ftang@netscape.com 2002-05-10 15:11 -------

Is this just translation issue? or this is an international issue?



------- Additional Comment #7 From Ying-Lin Xia 2002-05-10 15:42 -------

Don't kow yet. The strange thing here is, for Netscape WebMail, we see the 
translated "Inbox" and "Trash" folder, but the "Sent", "Draft" folders are 
still show English. In the client side, I believe we translated all folder 
names already (See screenshot local mail part), so where that 2 folders come 
from and why.

Removing jab1, let's work on it for RTM later.



------- Additional Comment #8 From Don Bragg 2002-05-30 10:28 -------

Adding ftang and Tao and nhotta per Tao's suggestion.



------- Additional Comment #9 From Naoki Hotta 2002-05-30 15:11 -------

Cc to naving, which file to edit in order to translate "Draft" and "Sent"?



------- Additional Comment #10 From kasumi 2002-05-30 17:26 -------

Yes.



------- Additional Comment #11 From Navin Gupta 2002-06-03 11:53 -------

messenger.properties



------- Additional Comment #12 From Ying-Lin Xia 2002-06-03 12:18 -------

I think messenger.properties is not for the webmail folder, cause we did 
traslate that file all, but... please see the screenshot above...



------- Additional Comment #13 From Navin Gupta 2002-06-03 14:06 -------

This problem will need to fixed. 



------- Additional Comment #14 From Navin Gupta 2002-06-04 13:34 -------

Created an attachment (id=6703)
proposed fix

The fix is to add a properties file so that Draft and Sent can be localized.
Also we need to have the pref where we can convertFolderNames to true. 



------- Additional Comment #15 From Navin Gupta 2002-06-04 13:37 -------

bhuvan, can I get r=? thx.



------- Additional Comment #16 From racham@netscape.com 2002-06-04 18:45 -------

(From update of attachment 6703 [details])
I think you should add 'Templates' also to the list of folders to be localized
along with Draft & Sent in netscape-imap.properies file.

Since the patch is small, Naoki (if he has some time) can probably help us 
with testing here.

r=bhuvan



------- Additional Comment #17 From Navin Gupta 2002-06-05 10:16 -------

The problem here is that the "Sent" folder is not selected as default "Sent" 
folder for webmail. Same is true for "Draft". But since we have "Drafts" 
normally, I will have to change so that we show localized name for "Draft".



------- Additional Comment #18 From Navin Gupta 2002-06-05 10:19 -------

Created an attachment (id=6742)
proposed fix

The fix is to allow "Draft" to be localized for netscape webmail. "Sent" is
already localized but doesn't show because MSG_FOLDER_FLAG_SENT is not set i.e
not selected as "Sent" folder. 



------- Additional Comment #19 From Navin Gupta 2002-06-05 10:21 -------

Cavin, David, Can I get reviews for last patch ? thx. 



------- Additional Comment #20 From bienvenu@netscape.com 2002-06-05 10:49 -------

(From update of attachment 6742 [details])
sr=bienvenu - to expand on what Navin was saying about the sent folder, it's
not a sent folder as far as we're concerned, because we don't put sent messages
in it - that's done on the server.



------- Additional Comment #21 From Cavin Song 2002-06-05 13:24 -------

(From update of attachment 6742 [details])
r=cavin.



------- Additional Comment #22 From Navin Gupta 2002-06-11 14:08 -------

fixed on trunk.



------- Additional Comment #23 From ftang@netscape.com 2002-06-12 13:47 -------

put [adt2] in the status so adt can find it. 



------- Additional Comment #24 From Jaime Rodriguez, Jr. 2002-06-12 14:23 -------

adt1.0.1+ (on ADT's behalf) approval for checkin to the 1.0 branch. pls check
this in asap, then add the "fixed1.0.1" keyword.
Posted patch proposed fixSplinter Review
This patch has r=cavin sr=bienvenu and has adt approval
Comment on attachment 87696 [details] [diff] [review]
proposed fix

r=cavin, sr=bienvenu
Attachment #87696 - Flags: superreview+
Attachment #87696 - Flags: review+
carry the nsbeta1+ and adt1.0.1+ from the bugscape bug.
Keywords: approval
Attachment #87696 - Flags: approval+
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Actually I found out that fix in bug 152406 is also needed to fix this bug. So
I'll have to wait for that bug to also get approved. 
bug 152406 has been approved by all parties. pls chekc in both fixes asap. thanks!
Blocks: 143047
Whiteboard: [adt2 RTM] [ETA 06/20]
Target Milestone: --- → mozilla1.0.1
fixed on branch
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
this was checked on trunk as well
Keywords: approval
Navi, please advise how we can verify this w/o a localized build. 
If you edit messenger.properties it should work 
Ying, I checked 7/18 branch build with 7/17 jaJP lang pack. Netscape Webmail
"Sent" and "Draft" are still in English. Does it require a localized build to
verify this (lang pack is not enough), could you take a look at this?
The JA messenger.properties in 07/17 lang pack is fully localized.
ianglan, I can see the folders are Japanese now, seems it's fixed. Why you
still see English folders? ;-)
It looks like the folders are in English right after the account is added. After
the browser is restarted, the folders appear in localized strings. 
I wonder why the folders are in English the first time after the account is added.
I'll take a look. 
when you log into the server then the prettyName would show up. I think it is
correct behavior. 
I saw that the folders didn't show in pretty names the first time connected to
the server.
Steps to reproduce:
1. Go to account manager.
2. Add one webmail account.
3. Login to the server. "Sent" and "Draft" are in English
4. Close browser and restart.
5. Login to webmail account, this time "Sent" and "Draft" are in Japanese.
QA contact to kasumi since this originally comes from her bug in bugzilla.
Kasumi, please test this with a localized build next week. If the problem I
mentioned at above comments still exists, please file a seperate bug for that.
Thanks.
QA Contact: ji → kasumi
tested on 2002-07-29-08-1.0-JA build
Original display problem is solved but as comment #18 said, first time opening
has display problem.
I will report it separately.
Status: RESOLVED → VERIFIED
Katsumi - can you verify this bug fix in 1.0?  When verified, pls replace
fixed1.0.1 keyword with verified1.0.1.  Thanks.
Keywords: verified1.0.1
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.