Closed Bug 1518934 Opened 9 months ago Closed 5 months ago

Crash in mozilla::widget::WaylandShmPool::CreateTemporaryFile

Categories

(Core :: Widget: Gtk, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1543687
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- affected

People

(Reporter: marcia, Assigned: stransky)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-dedda2d3-13d9-497f-bd48-4ca250181213.

Seen while looking at nightly crash data. Linux crashes started when nightly was in 65: https://bit.ly/2AGkO8O. 6 crashes/6 installs in the last 2 weeks.

ni on :stranksy since it appears he worked in this area.

Top 10 frames of crashing thread:

0 libxul.so mozilla::widget::WaylandShmPool::CreateTemporaryFile widget/gtk/WindowSurfaceWayland.cpp:180
1 libxul.so mozilla::widget::WaylandShmPool::WaylandShmPool widget/gtk/WindowSurfaceWayland.cpp:187
2 libxul.so mozilla::widget::WindowBackBuffer::WindowBackBuffer widget/gtk/WindowSurfaceWayland.cpp:273
3 libxul.so mozilla::widget::WindowSurfaceWayland::GetWaylandBufferToDraw widget/gtk/WindowSurfaceWayland.cpp:386
4 libxul.so mozilla::widget::WindowSurfaceWayland::LockWaylandBuffer widget/gtk/WindowSurfaceWayland.cpp:446
5 libxul.so mozilla::widget::WindowSurfaceWayland::Lock widget/gtk/WindowSurfaceWayland.cpp:506
6 libxul.so mozilla::widget::WindowSurfaceProvider::StartRemoteDrawingInRegion widget/gtk/WindowSurfaceProvider.cpp:114
7 libxul.so mozilla::layers::BasicCompositor::BeginFrame gfx/layers/basic/BasicCompositor.cpp:850
8 libxul.so mozilla::layers::LayerManagerComposite::EndTransaction gfx/layers/composite/LayerManagerComposite.cpp:887
9 libxul.so mozilla::layers::CompositorBridgeParent::CompositeToTarget gfx/layers/ipc/CompositorBridgeParent.cpp:993

=============================================================

Flags: needinfo?(stransky)

Okay, Thanks!

Assignee: nobody → stransky
Flags: needinfo?(stransky)

I think it's because there's no space left at tmp to create the mapping file. But let's produce a better diagnose for that - Bug 1519355

Martin do you think you will now be able to fix this with bug 1519355 fixed or should we mark 65 as wontfix, considering we're running out of time for uplifts for 65.

Flags: needinfo?(stransky)

It should be marked as wontfix, I don't see any new crashes with this signature. I'll investigate it if there's anything new.

Flags: needinfo?(stransky)

Martin, there are crash signatures from Feb 28 to Mar 3. Can you please look into this for the 67 soft freeze (Mar 11)?

Flags: needinfo?(stransky)

Unfortunately there's nothing new at the reports, I may need to put more debugging info/logging to the failure.

Flags: needinfo?(stransky)
Keywords: regression

Let's handle it at Bug 1543687.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1543687
You need to log in before you can comment on or make changes to this bug.