Closed Bug 1543687 Opened 2 years ago Closed 1 year ago

[Wayland] posix_fallocate() causes massive hangs on wayland on popup creation

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: emilio, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Crash Data

Without WebRender enabled, I see very frequent hangs in the latest Nightly build.

Took a profile of one of them, seems we're expending a lot of time waiting to create a window back buffer:

Is this something that changed recently? I'm not sure, since I always use WR...

Flags: needinfo?(stransky)

It hangs at posix_fallocate() - we may consider to replace it by fallocate() on linux. This call generally depends on your system/file system/kernel version etc.

Flags: needinfo?(stransky)
Summary: Massive hangs on wayland on popup creation → posix_fallocate() causes massive hangs on wayland on popup creation
Summary: posix_fallocate() causes massive hangs on wayland on popup creation → [Wayland] posix_fallocate() causes massive hangs on wayland on popup creation
No longer blocks: wayland
Regressed by: wayland
Priority: -- → P5

This may be fixed when we switch to IPC Shm memory backend for wl_buffers.

Priority: P5 → P3

WindowBackBufferShm needs to be moved to gfx/2d and implemented on top of IPC Shm memory. We should not allocate our own shm at widget/gtk.

Duplicate of this bug: 1518934
Crash Signature: [@ mozilla::widget::WaylandShmPool::CreateTemporaryFile]

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.