Closed Bug 1519396 Opened 9 months ago Closed 9 months ago

'Force Attribution' from ASRouter for Return to AMO does not work on Windows

Categories

(Firefox :: Messaging System, defect, P1, major)

66 Branch
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox66 --- verified

People

(Reporter: vlad.jiman, Assigned: andreio)

References

(Blocks 1 open bug)

Details

(Keywords: github-merged)

Attachments

(1 file)

In order to force attribute and see the 'Add the Extension' page, which is the first page the user will see after installing Firefox with Return to AMO enabled, we use the asrouter - force attribute, method which currently only works on OSX.

Steps:

  1. Using a Nightly build go to about:config and set the following prefs:
  • browser.newtabpage.activity-stream.asrouter.devtoolsEnabled = true
  • browser.newtabpage.activity-stream.asrouter.providers.onboarding set to:
    {"id":"onboarding","type":"local","localProvider":"OnboardingMessageProvider","enabled":true,"exclude":[]}
  1. Go to about:newtab#asrouter, Targeting tab and scroll to the bottom of the page
  2. Select Force Attribution and open a new tab with about:welcome url

Expected:
The iridium extension install page should be seen (or whichever extension was used with force attribution).

Actual:
For windows platforms the force attribution does not appear to do anything, so the FxA sign-on page is shown instead.

Assignee: nobody → andrei.br92
Blocks: 1468680
Summary: The API used to force attribution from ASRouter for Return to AMO does not work on Windows → 'Force Attribution' from ASRouter for Return to AMO does not work on Windows
Component: General → Activity Streams: Newtab
Product: WebExtensions → Firefox
Blocks: 1515411
Commit pushed to master at https://github.com/mozilla/activity-stream

https://github.com/mozilla/activity-stream/commit/2a10f2fb869835b5f3c7f45be8f38a773ac42304
Bug 1519396 - 'Force Attribution' from ASRouter for Return to AMO does not work on Windows (#4656)
Blocks: 1520691
Iteration: --- → 66.3 - Jan 7 - 20
Keywords: github-merged
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Priority: -- → P1

Validated using Windows 10 x64 bit with Nightly 66.0a1 build (20190120213632). The issue is no longer reproducing on this build.

Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → Messaging System
You need to log in before you can comment on or make changes to this bug.