Perma dt browser/base/content/test/static/browser_parsable_css.js | Got error message for chrome://devtools/skin/webconsole.css: Unknown property ‘overflow-anchor’. Declaration dropped. - when Gecko 66 merges to Beta on 2019-01-21

VERIFIED FIXED in Firefox 66

Status

()

defect
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: apavel, Assigned: rhunt)

Tracking

(Blocks 1 bug)

unspecified
Firefox 66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(geckoview64 unaffected, geckoview65 unaffected, geckoview66 unaffected, firefox-esr60 unaffected, firefox64 unaffected, firefox65 unaffected, firefox66+ fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago

[Tracking Requested - why for this release]:

Central as Beta simulation

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=f5611df0e7ca0404394666f66aeafb850ba60061&selectedJob=221318205

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=221318205&repo=try&lineNumber=1390

05:18:58 INFO - TEST-START | browser/base/content/test/static/browser_all_files_referenced.js
05:19:06 INFO - GECKO(843) | MEMORY STAT vsizeMaxContiguous not supported in this build configuration.
05:19:06 INFO - GECKO(843) | MEMORY STAT | vsize 4691MB | residentFast 677MB | heapAllocated 456MB
05:19:06 INFO - TEST-OK | browser/base/content/test/static/browser_all_files_referenced.js | took 8098ms
05:19:06 INFO - checking window state
05:19:06 INFO - TEST-START | browser/base/content/test/static/browser_parsable_css.js
05:19:06 INFO - TEST-INFO | started process screencapture
05:19:06 INFO - TEST-INFO | screencapture: exit 0
05:19:06 INFO - <snipped 39 output lines - if you need more context, please use SimpleTest.requestCompleteLog() in your test>
05:19:06 INFO - Buffered messages logged at 05:19:06
05:19:06 INFO - Console message: [JavaScript Warning: "Unknown property ‘user-select’. Declaration dropped." {file: "resource://devtools/client/debugger/new/dist/debugger.css?always-parse-css-0.3123381262706779" line: 4624}]
05:19:06 INFO - Console message: [JavaScript Warning: "Unknown pseudo-class or pseudo-element ‘-moz-native-anonymous’. Ruleset ignored due to bad selector." {file: "resource://devtools/server/actors/highlighters.css?always-parse-css-0.3123381262706779" line: 15}]

05:19:07 INFO - Console message: [JavaScript Warning: "Unknown property ‘user-select’. Declaration dropped." {file: "resource://devtools/client/shared/components/reps/reps.css" line: 325}]
05:19:07 INFO - Buffered messages finished
05:19:07 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/static/browser_parsable_css.js | Got error message for chrome://devtools/skin/webconsole.css: Unknown property ‘overflow-anchor’. Declaration dropped. -
05:19:07 INFO - Stack trace:
05:19:07 INFO - chrome://mochikit/content/browser-test.js:test_ok:1305
05:19:07 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:messageIsCSSError:243
05:19:07 INFO - chrome://mochitests/content/browser/browser/base/content/test/static/browser_parsable_css.js:checkAllTheCSS:442
05:19:07 INFO - Ignored error "Unknown property ‘user-select’. Declaration dropped." on resource://devtools-client-shared/components/reps/reps.css because of whitelist item {"sourceName":"/devtools-client-shared\/components\/reps\/reps.css/i","isFromDevTools":true,"used":true}
05:19:07 INFO - Ignored error "Unknown property ‘user-select’. Declaration dropped." on resource://devtools/client/debugger/new/dist/debugger.css because of whitelist item {"sourceName":"/devtools\/client\/debugger\/new\/dist\/debugger.css/i","isFromDevTools":true,"used":true}

Ryan, this seems to be from bug 1305957, please take a look.

Flags: needinfo?(rhunt)
Assignee

Comment 1

5 months ago

Looks like we need to add 'overflow-anchor' to that test [1] while it's behind a nightly-only preference.

[1] https://searchfox.org/mozilla-central/rev/b4ebbe90ae4d0468fe6232bb4ce90699738c8125/browser/base/content/test/static/browser_parsable_css.js

Assignee: nobody → rhunt
Flags: needinfo?(rhunt)
Assignee

Updated

5 months ago

After importing the patch D16404 which imported D16275 as well into central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=1c6cd4f780f78385d99f72b6469058b59b1b840c&selectedJob=221587572

Is causing new perma failures: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=221587572&repo=try&lineNumber=3732
Seems related to: 1518626

[task 2019-01-13T13:16:29.049Z] 13:16:29 INFO - TEST-START | /css/css-scroll-anchoring/multicol-fragmented-anchor.html
[task 2019-01-13T13:16:29.050Z] 13:16:29 INFO - Closing window 72
[task 2019-01-13T13:16:29.167Z] 13:16:29 INFO - PID 2062 | ++DOCSHELL 0xd41cb800 == 23 [pid = 2062] [id = {0f25decc-9b5b-4e85-80f1-d67e8edb333d}]
[task 2019-01-13T13:16:29.168Z] 13:16:29 INFO - PID 2062 | ++DOMWINDOW == 66 (0xd38d4090) [pid = 2062] [serial = 75] [outer = (nil)]
[task 2019-01-13T13:16:29.170Z] 13:16:29 INFO - PID 2062 | ++DOMWINDOW == 67 (0xd485bc00) [pid = 2062] [serial = 76] [outer = 0xd38d4090]
[task 2019-01-13T13:16:29.231Z] 13:16:29 INFO - PID 2062 | ++DOMWINDOW == 68 (0xd4cf0000) [pid = 2062] [serial = 77] [outer = 0xd38d4090]
[task 2019-01-13T13:16:29.614Z] 13:16:29 INFO -
[task 2019-01-13T13:16:29.615Z] 13:16:29 INFO - TEST-UNEXPECTED-FAIL | /css/css-scroll-anchoring/multicol-fragmented-anchor.html | An element in a fragmented div should be able to be selected as an anchor node. - assert_equals: expected 20 but got 0
[task 2019-01-13T13:16:29.615Z] 13:16:29 INFO - @http://web-platform.test:8000/css/css-scroll-anchoring/multicol-fragmented-anchor.html:53:3
[task 2019-01-13T13:16:29.615Z] 13:16:29 INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1566:20
[task 2019-01-13T13:16:29.616Z] 13:16:29 INFO - test@http://web-platform.test:8000/resources/testharness.js:544:21
[task 2019-01-13T13:16:29.616Z] 13:16:29 INFO - @http://web-platform.test:8000/css/css-scroll-anchoring/multicol-fragmented-anchor.html:39:1

Flags: needinfo?(rhunt)
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

5 months ago
Duplicate of this bug: 1519846

Comment 6

5 months ago
Pushed by rhunt@eqrion.net:
https://hg.mozilla.org/integration/autoland/rev/3fd5d8f120c7
Fix browser_parsable_css.js for scroll-anchoring as it's behind a pref. r=emilio
Assignee

Comment 7

5 months ago

I accidentally had those two commits linked in Phabricator, so you pulled in an extra patch that's not needed/not ready. You should just need the one patch to fix the failure. I've just pushed it with lando, so it should go to central soon.

Assignee

Updated

5 months ago
Flags: needinfo?(rhunt)

Comment 8

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
You need to log in before you can comment on or make changes to this bug.