Closed Bug 1519967 Opened 10 months ago Closed 9 months ago

Change richlistbox to use getBoundingClientRect instead of boxObject

Categories

(Core :: XUL, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: enndeakin, Assigned: enndeakin)

References

Details

Attachments

(1 file)

This patch also replaces some calls to clientHeight with getBoundingClientRect().height which for some reason bug 1472557 changed. I think we should use the original intent here as getBoundingClientRect().height will return the border-box as boxObject.height does whereas clientHeight returns the padding-box.

Priority: -- → P3
Attachment #9036416 - Flags: review?(paolo.mozmail)
Comment on attachment 9036416 [details] [diff] [review]
Don't use the box object in richlistbox

Review of attachment 9036416 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/widgets/richlistbox.js
@@ +730,5 @@
>      if (!aItem) {
>        return false;
>      }
>  
> +    var y = this.getBoundingClientRect().y;

I guess this.getBoundingClientRect().y == this.scrollTop + this.boxObject.y, so r+ if that's correct.

Again, worth landing after soft code freeze because regressions here might be more difficult to notice.
Attachment #9036416 - Flags: review?(paolo.mozmail) → review+
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/75b0a937397c
remove box object computations in richlistbox, r=paolo
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.