Closed Bug 1520001 Opened Last year Closed 7 months ago

[BinAST] Port from webidl.rs to weedle

Categories

(Core :: JavaScript Engine, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: Yoric, Assigned: Yoric)

References

Details

Attachments

(7 files)

This will reduce the size of dependencies.

Assignee: nobody → dteller

This should save a lot of Rust dependencies. Due to problems with arcanist/moz-phab, this is a single revision with all the changes, both the manual changes to Cargo.toml and rust source code and the automated changes
caused by ./mach vendor rust.

Priority: -- → P2
See Also: → 1527861
Priority: P2 → P1
Depends on: 1529117
Priority: P1 → P2

Not sure why this wasn't done before, but it prevented me from running ./mach rust vendor.

Pushed by dteller@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67a419419e6a
dependency cloudabi is BSD-2 and must appear in about:license;r=mhoye
https://hg.mozilla.org/integration/autoland/rev/3796bc3ddbc2
Updating binast generator to binjs_meta 0.5.2;r=arai
https://hg.mozilla.org/integration/autoland/rev/0a318f35750c
Propagating binjs_meta 0.5.2 changes to files generated by binast generator;r=arai
https://hg.mozilla.org/integration/autoland/rev/8a1693341eac
Porting binjs_meta to Itertools 0.8;r=arai
https://hg.mozilla.org/integration/autoland/rev/aba8e19920fa
mach rust vendor;r=arai,smaug

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.