Closed Bug 1520068 Opened 9 months ago Closed 7 months ago

Re-assigning to Ctrl+Page Up/Page Down executes shortcut

Categories

(WebExtensions :: Frontend, defect, P2)

66 Branch
Unspecified
Linux
defect

Tracking

(firefox65 wontfix, firefox66 wontfix, firefox67 verified)

VERIFIED FIXED
mozilla67
Tracking Status
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- verified

People

(Reporter: freaktechnik, Assigned: mstriemer)

References

Details

Attachments

(2 files)

Steps to reproduce:

  • Go to new extensions shortcut reassigning UI (Manage Extension Shortcuts) from bug 1303384
  • Select a command to re-assign
  • Assign "Ctrl + Page Up"

Expected result:
Error is shown that a built-in command can not be used.

Actual result:
The tab is switched (that's the action of "Ctrl + Page Up/Page Down", at least on Linux) and the command is seemingly assigned that shortcut without any error message being shown.

Depends on: 1303384
Blocks: 1303384
No longer depends on: 1303384

I'm curious how that shortcut is registered, but it would be nice to handle this. Provided there are <key>s registered for them it should be fixable, but I would've expected this to work as expected if that's the case.

Priority: -- → P2

Perhaps it's not checking the "Page Up" key the right way.

That looks like the issue, thanks. It appears as though there is also a Ctrl+F4 shortcut to close the selected tab(s) when not on Mac that would need to be handled.

Note: Yes, Ctrl+F4 was reported here

This centralizes the checks for system shortcuts into ShortcutUtils.jsm, so
they can be checked for in the add-on shortcut assignment UI. It also
introduces a mechanism for skipping the system event handler if it is already
being handled by the shortcuts UI.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4f506f386199
Handle more system shortcuts in add-on shortcuts ui r=dao
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: nobody → mstriemer
Attached image Bug1520068.gif

This issue is verified as fixed on Firefox 67.0a1 (20190314214219) under Win 7 64-bit and Mac OS X 10.12.6.

"Ctrl + Page Up/Page Down" can’t be assigned and the “Can’t override a Nightly shortcut” label is displayed.

Please see the attached screenshot.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.