Closed Bug 1520126 Opened 2 years ago Closed 2 years ago

Text affected by will-change: transform is rendered blurry for uneven window widths

Categories

(Core :: Graphics: WebRender, defect, P1)

66 Branch
Unspecified
All
defect

Tracking

()

VERIFIED FIXED
mozilla66
Root Cause Design Error
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 blocking verified
firefox67 --- verified

People

(Reporter: ke5trel, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

Ubuntu 18.10 with AMD BARTS.

Some text on Bugzilla is blurry at uneven window widths with webrender enabled. Resizing the window causes text to alternate between blurry and sharp for each pixel resized. Disabling #bugzilla-body's will-change: transform avoids the problem.

Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=25b80743d6504a24c2e9a981e38cd7ed0fd3b7d5&tochange=58b0b6fba4c388a12b98954772074ffbfc81c784

Regressed by: Bug 1512010

Flags: needinfo?(lsalzman)
Priority: -- → P3

This is pretty jarring and should probably block the WR experiments from starting on Beta66.

Priority: P3 → P2
Severity: normal → critical

I can also reproduce the issue on windows10 if webrender is enabled

OS: Linux → All
Priority: P2 → P1

On macOS, it looks not so bad like the attached screenshot but yet blurry, as :marcia let me know. On Linux, due to Bug 1428595, things may become worse than other platforms. will-change:transform has been added in Bug 1469733 to enable smooth scroll on Safari so I think we cannot remove it.

Duplicate of this bug: 1520215

Backed out bug 1512010 for now until I can come up with a better solution.

Flags: needinfo?(lsalzman)

Fixed by backout.

Assignee: nobody → lsalzman
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

I managed to reproduce the issue using an older version of Nightly (2019-01-15) on Ubuntu 18.04 x64 and macOS 10.13.
I retested everything using the latest Nightly 67.0a1 and beta 66.0b14 on Ubuntu 18.04 x64, Windows 10 x64 and macOS 10.13. The bug is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?
Root Cause: ? → Design Error
You need to log in before you can comment on or make changes to this bug.