Closed Bug 1520275 Opened 7 months ago Closed 7 months ago

Add a primitive debug display

Categories

(Core :: Graphics, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: bholley, Assigned: bholley)

Details

Attachments

(1 file)

Glenn showed me how to hack in highlighting for text runs. This turned out to be really useful, so I generalized it for all primitives and hooked it up to about:config.

Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b1911ea8b8b
Add primitive debug display. r=gw
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76a02546878f
Backed out changeset 0b1911ea8b8b for qr wrench bustages. CLOSED TREE

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=success%2Ctestfailed%2Cbusted%2Cexception&fromchange=0b1911ea8b8b9168ec413904aae1bdab30d5ad87&tochange=28bcc4da309251ab6c1f10a3d4e67c1c55ee4fad&searchStr=wrench&selectedJob=222270954

Failures log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=222270954&repo=autoland&lineNumber=371

Backout link: https://hg.mozilla.org/integration/autoland/rev/76a02546878ffda22bd394b57b0708f89f2fa0fc

[task 2019-01-16T19:06:30.661Z] Compiling webrender v0.58.0 (/builds/worker/checkouts/gecko/gfx/wr/webrender)
[task 2019-01-16T19:06:30.661Z] Running rustc --crate-name build_script_build webrender/build.rs --color never --crate-type bin --emit=dep-info,link -C debuginfo=2 -C metadata=4002b8c35785f56e -C extra-filename=-4002b8c35785f56e --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/build/webrender-4002b8c35785f56e -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern webrender_build=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwebrender_build-f31f6268d83c62bf.rlib --deny warnings
[task 2019-01-16T19:06:31.168Z] Running /builds/worker/checkouts/gecko/gfx/wr/target/debug/build/gleam-7fb79f3f74b45433/build-script-build
[task 2019-01-16T19:06:31.185Z] Running /builds/worker/checkouts/gecko/gfx/wr/target/debug/build/webrender-4002b8c35785f56e/build-script-build
[task 2019-01-16T19:06:36.815Z] Running rustc --crate-name gleam /builds/worker/checkouts/gecko/gfx/wr/vendor/gleam/src/lib.rs --color never --crate-type lib --emit=dep-info,link -C debuginfo=2 -C metadata=8d3f98c280fac98c -C extra-filename=-8d3f98c280fac98c --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/deps -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --cap-lints allow --deny warnings
[task 2019-01-16T19:06:45.301Z] Running rustc --crate-name webrender webrender/src/lib.rs --color never --crate-type lib --emit=dep-info,link -C debuginfo=2 -C metadata=18121e25a0924810 -C extra-filename=-18121e25a0924810 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/deps -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern app_units=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libapp_units-68551dda5fcbe290.rlib --extern bincode=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbincode-7fb2a4c0da76e088.rlib --extern bitflags=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbitflags-96590e15879d8379.rlib --extern byteorder=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbyteorder-13de9f0794db42e3.rlib --extern cfg_if=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libcfg_if-59f218f06168322b.rlib --extern freetype=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libfreetype-3052aa13ee9e558c.rlib --extern fxhash=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libfxhash-e133ec5d9ed054e0.rlib --extern gleam=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libgleam-8d3f98c280fac98c.rlib --extern lazy_static=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblazy_static-1d1fbac54a2f817f.rlib --extern libc=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblibc-74f87a5931a4f438.rlib --extern log=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblog-6e1feae5bfcc8198.rlib --extern malloc_size_of_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libmalloc_size_of_derive-dc0d53c6d7b78806.so --extern num_traits=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libnum_traits-d132d685f2004180.rlib --extern plane_split=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libplane_split-b4a39493ad0797d3.rlib --extern rayon=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/librayon-5bfbe8a6b36a2df1.rlib --extern sha2=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libsha2-ef3d165706dc556d.rlib --extern smallvec=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libsmallvec-166304b88bc8df9b.rlib --extern thread_profiler=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libthread_profiler-63a28c2cb49bedfb.rlib --extern time=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libtime-c947684c45759b42.rlib --extern webrender_api=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwebrender_api-889e17a424612c1e.rlib --extern webrender_build=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwebrender_build-f31f6268d83c62bf.rlib --extern wr_malloc_size_of=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwr_malloc_size_of-3bd7116b96269af8.rlib --deny warnings
[task 2019-01-16T19:06:46.253Z] error: unused import: DebugFlags
[task 2019-01-16T19:06:46.253Z] --> webrender/src/prim_store/mod.rs:5:43
[task 2019-01-16T19:06:46.253Z] |
[task 2019-01-16T19:06:46.253Z] 5 | use api::{BorderRadius, ClipMode, ColorF, DebugFlags, PictureRect, ColorU, LayoutVector2D};
[task 2019-01-16T19:06:46.253Z] | ^^^^^^^^^^
[task 2019-01-16T19:06:46.253Z] |
[task 2019-01-16T19:06:46.253Z] = note: -D unused-imports implied by -D warnings
[task 2019-01-16T19:06:46.253Z]
[task 2019-01-16T19:06:49.473Z] error: aborting due to previous error
[task 2019-01-16T19:06:49.473Z]
[task 2019-01-16T19:06:49.493Z] error: Could not compile webrender.
[task 2019-01-16T19:06:49.493Z]
[task 2019-01-16T19:06:49.493Z] Caused by:
[task 2019-01-16T19:06:49.493Z] process didn't exit successfully: rustc --crate-name webrender webrender/src/lib.rs --color never --crate-type lib --emit=dep-info,link -C debuginfo=2 -C metadata=18121e25a0924810 -C extra-filename=-18121e25a0924810 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/deps -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern app_units=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libapp_units-68551dda5fcbe290.rlib --extern bincode=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbincode-7fb2a4c0da76e088.rlib --extern bitflags=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbitflags-96590e15879d8379.rlib --extern byteorder=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libbyteorder-13de9f0794db42e3.rlib --extern cfg_if=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libcfg_if-59f218f06168322b.rlib --extern freetype=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libfreetype-3052aa13ee9e558c.rlib --extern fxhash=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libfxhash-e133ec5d9ed054e0.rlib --extern gleam=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libgleam-8d3f98c280fac98c.rlib --extern lazy_static=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblazy_static-1d1fbac54a2f817f.rlib --extern libc=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblibc-74f87a5931a4f438.rlib --extern log=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/liblog-6e1feae5bfcc8198.rlib --extern malloc_size_of_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libmalloc_size_of_derive-dc0d53c6d7b78806.so --extern num_traits=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libnum_traits-d132d685f2004180.rlib --extern plane_split=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libplane_split-b4a39493ad0797d3.rlib --extern rayon=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/librayon-5bfbe8a6b36a2df1.rlib --extern sha2=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libsha2-ef3d165706dc556d.rlib --extern smallvec=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libsmallvec-166304b88bc8df9b.rlib --extern thread_profiler=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libthread_profiler-63a28c2cb49bedfb.rlib --extern time=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libtime-c947684c45759b42.rlib --extern webrender_api=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwebrender_api-889e17a424612c1e.rlib --extern webrender_build=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwebrender_build-f31f6268d83c62bf.rlib --extern wr_malloc_size_of=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libwr_malloc_size_of-3bd7116b96269af8.rlib --deny warnings (exit code: 1)
[taskcluster 2019-01-16 19:06:51.110Z] === Task Finished ===
[taskcluster 2019-01-16 19:06:51.110Z] Unsuccessful task run with exit code: 101 completed in 186.69 seconds

Flags: needinfo?(bobbyholley)
Pushed by bholley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba1ee17a47e9
Add primitive debug display. r=gw
Flags: needinfo?(bobbyholley)
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
You need to log in before you can comment on or make changes to this bug.