Closed Bug 1520463 Opened 10 months ago Closed 23 days ago

Raptor python unit tests: add support for python 3

Categories

(Testing :: Raptor, enhancement, P1)

Version 3
enhancement

Tracking

(firefox71 wontfix, firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox71 --- wontfix
firefox72 --- fixed

People

(Reporter: Bebe, Assigned: rwood)

References

(Depends on 3 open bugs, Blocks 1 open bug)

Details

(Whiteboard: [lang=py])

Attachments

(1 file, 1 obsolete file)

Update python unit tests to run on python 3

To work on this, remove "skip-if = python == 3" from testing/raptor/test/python.ini and run the tests using mach python-test --python=3.5 testing/raptor/test. You will see several failures related to code that is not ready for Python 3.

We should also ensure there are no linting errors after enabling py2/py3 linting on testing/raptor. This can be done be removing the exclusions in tools/lint/py2.yml and tools/lint/py3.yml and running mach lint testing/raptor.

Keywords: good-first-bug
Priority: -- → P3
Whiteboard: [lang=py]

Hi, I'd like to work on this issue

Hi, I am new to the community. I am an experienced Python programmer. Can someone please guide me on how to proceed.

I think the first steps would be to get your raptor environment

See: https://wiki.mozilla.org/Performance_sheriffing/Raptor#Running_Locally

Note: When building Firefox use "Artifact builds"

After you have a working build and can run a Raptor test back to comment 1

(In reply to Agboola Mukhtar <agbo-ola> from comment #2)

Hi, I'd like to work on this issue

(In reply to cbseadarsh from comment #3)

Hi, I am new to the community. I am an experienced Python programmer. Can someone please guide me on how to proceed.

Hey Agboola and cbseadarsh! Thank you for your interested in working on this bug. You're both welcome to look into this issue, however we'll most likely only be able to accept a patch from one of you.

As Bebe suggests, a working Raptor environment would be useful, however I'm not sure if it's a requirement for getting the tests running in Python 3.

To work on this bug you will need to install and configure Mercurial, which will enable you to download the Firefox source code. It will also be used to commit your changes locally and prepare a patch for review. See the installation guide for help getting Mercurial on your system. Once installed, there are some extensions we recommend installing, details of these can be found here.

To clone the Firefox source code we recommend using the unified repository. Details of this and how to create a bookmark for your work can be found here.

As this bug relates to Python 3, you will need to have this installed on your system. Our continuous integration is currently using Python 3.5, so for best results we recommend using the same version locally. There are a number of ways to install Python, and they vary depending on your environment. We suggest reading over these guides to find the best method for you. Note that we also need to maintain support for Python 2, so you'll also need to have Python 2.7 installed.

Whilst we're moving towards adding support for Python 3, we've disabled any tests that fail against this version. This means that in order to work on this bug you will need to enable the tests. This can be done by removing "skip-if = python == 3" from the manifest file in testing/raptor/test/python.ini

To run the tests against Python 3, execute the following command:

mach python-test --python=3.5 testing/raptor/test

As mentioned in comment 1, we should also ensure there are no linting errors after enabling py2/py3 linting on testing/raptor. This can be done be removing the exclusions in tools/lint/py2.yml and tools/lint/py3.yml and running mach lint testing/raptor.

Hi. On running the tests using python 3.5 I got errors like this -

 0:35.86 c:\mozilla-unified\testing\raptor\test\test_manifest.py
 0:35.87 Traceback (most recent call last):
 0:35.87   File "c:\mozilla-unified\testing\raptor\test\test_manifest.py", line 22, in <module>
 0:35.88     from manifest import get_browser_test_list, validate_test_ini, get_raptor_test_list
 0:35.88   File "c:\mozilla-unified\testing\raptor\raptor\manifest.py", line 9, in <module>
 0:35.88     from manifestparser import TestManifest
 0:35.89   File "c:\mozilla-unified\testing\raptor\test\../../mozharness\manifestparser\__init__.py", line 6, in <module>
 0:35.89     from .manifestparser import *
 0:35.90   File "c:\mozilla-unified\testing\raptor\test\../../mozharness\manifestparser\manifestparser.py", line 5, in 
           <module>
 0:35.90     from StringIO import StringIO
 0:35.90 ImportError: No module named 'StringIO'

Python 3 doesnn't have StringIO and cStringIO modules so we have to import it using os module. But if we change that the tests would fail on python 2. How am I supposed to update the unit tests showing these errors to make them run both on Python 2 and Python 3

The six package is available within the virtual environment that our tests run in. This package can be used to support both Python 2 and Python 3 code by providing a layer of abstraction. For example, six.StringIO resolves to StringIO.StringIO in Python 2 and io.StringIO in Python 3.

The error you're seeing is however not in the Raptor codebase, but in manifestparser, which is a dependency of Raptor. The work to support Python 3 in manifestparser is being tracked in bug 1428705. There hasn't been a lot of activity on that bug, so I've just prompted the assignee to see if they're still interested in working on it.

Depends on: 1428705
Depends on: mozbase-py3

I fixed the print errors to make the code run in python 3. Could you please guide me to fix the remaining errors.

Here are the errors I'm getting - https://pastebin.com/t1th77m0

Most of the errors are in the import statements. Could you guide me on how to fix them as well

(In reply to Utkarsh from comment #8)

I fixed the print errors to make the code run in python 3. Could you please guide me to fix the remaining errors.

Here are the errors I'm getting - https://pastebin.com/t1th77m0

Most of the errors are in the import statements. Could you guide me on how to fix them as well

It looks like a lot of these are due to dependencies. One that I noticed can be fixed within Raptor codebase is:

ImportError: No module named 'BaseHTTPServer'

This can be fixed using six:

from six.move import BaseHTTPServer

Hello, my name is Erik and I would like to work on this issue if no one is working on it anymore. Thanks.

:davehunt I made the necessary changes but on pushing the changes using arc diff I am getting this error - https://pastebin.com/dP9DApp6

Could you tell me what I'm doing wrong

Updated Python tests in Raptor to run in python 3.

:davehunt What should I work on now?

As mentioned in the review, there is a reference to BaseHTTPServer in testing/raptor/raptor/control_server.py, which is causing a failure.

For the other issues, I'm surprised to find that we have mozbase code duplicated in mozharness. I suspect many of these exceptions could be resolved by updating the code in:

  • testing/mozharness/manifestparser
  • testing/mozharness/mozprocess
  • testing/mozharness/mozinfo

With their respective packages in testing/mozbase.

It also looks like we'd need to update mozharness itself to support Python 3.

:ahal is there a process in place for updating the code duplication in mozharness?

I've opened bug 1532427 for taking care of supporting Python 3 in mozharness - perhaps this is something you're interested in, Utkarsh?

No longer depends on: 1532427
Flags: needinfo?(ahal)

No, you'll just have to copy/paste the srcdirs from one to the other.

Ideally we would remove these packages though, see bug 1195299. I think the reason we couldn't easily remove them before was because of the way mozharness was packaged into buildbot tasks. Now that we are 100% taskcluster, I think it should be easy to package external files into the mozharness.zip everywhere. Looks like no one as attempted for at least 3 years. I'm going to write a quick patch and test it out.

Flags: needinfo?(ahal)

Should also mention that updating the versions of mozbase under testing/mozharness should be a pre-requisite to removing them (as removing them would also cause them to get updated). Better to do this in two steps so we can identify and debug regressions easier.

In otherwords, don't block on that bug or anything.

It looks like bug 1195299 has been resolved. I suspect we still need to fix bug 1532427 before we can move forward on this, but it might be worth revisiting now. Are you still interested in working on this Utkarsh?

Flags: needinfo?(f20160600)

Hi, I'd like to work on this issue

(In reply to Anurag Aggarwal from comment #18)

Hi, I'd like to work on this issue

Thanks for you interest! Unfortunately this is dependant on bug 1532427, which is still unresolved, so this might not be suitable to work on just now. Is there another bug from https://codetribute.mozilla.org/projects/automation?project%3DRaptor or https://codetribute.mozilla.org/projects/automation?project%3DTalos?

Flags: needinfo?(f20160600)
Assignee: nobody → rwood
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: Update/Fix Raptor unit tests to run on python3 → Raptor python unit tests: add support for python 3
Keywords: good-first-bug

I would like work on this with pytest, if its ok @Robert

(In reply to Rajib Mitra from comment #20)

I would like work on this with pytest, if its ok @Robert

Hi Rajib, I have already started this and have assigned it to myself, as I will be working on the overall python 3 migration for the Raptor framework. Thanks for your interest - perhaps you can find a different issue to contribute to. We could always use more Raptor python unit tests added where you see fit (Bug 1532365 for example), or maybe you will find a good-first-bug on another project that you prefer more. Thanks!

Attachment #9046295 - Attachment is obsolete: true

(In reply to Robert Wood [:rwood] from comment #26)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d6d8b24f4127a6cc53c469e2bef9ed62a9ef4819

Looks like there are issues on Py3 Linux x64 that I need to investigate.

Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a4ed297ed157
Raptor python unit tests: add support for python 3 r=ahal
Status: ASSIGNED → RESOLVED
Closed: 26 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
See Also: → 1589842
Regressions: 1589842

Backed out changeset a4ed297ed157 (Bug 1520463) for raptor failures complaining about StringIO

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&selectedJob=272027180&revision=b98968eb71d373db989f6dbf0066194e6c75531a

Backout link: https://hg.mozilla.org/integration/autoland/rev/530ff0c5938780c0e3a0e62a9d1d5716f2e61f7a

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=272027180&repo=mozilla-central&lineNumber=909

[task 2019-10-19T11:49:47.087Z] 11:49:47 INFO - raptor-control-server Info: received webext_status: saving gecko profile
[task 2019-10-19T11:49:47.088Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.088Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] raptor-wasm-godot-cranelift-firefox_pagecycle_3.profile"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] stopping gecko profiling"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] stopping gecko profiling"
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - raptor-control-server Info: received gecko profile filename: raptor-wasm-godot-cranelift-firefox_pagecycle_3.profile
[task 2019-10-19T11:49:47.116Z] 11:49:47 INFO - raptor-control-server Info: moved gecko profile to /tmp/tmp1er_Lt/raptor-wasm-godot-cranelift-firefox_pagecycle_3.profile
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - raptor-control-server Info: received webext_status: stopping gecko profiling
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - raptor-control-server Info: received webext_results: {u'expected_browser_cycles': 1, u'subtest_unit': u'ms', u'name': u'raptor-wasm-godot-cranelift-firefox', u'extra_options': [u'gecko_profile'], u'lower_is_better': True, u'measurements': {u'wasm-godot': [[[{u'name': u'wasm-instantiate', u'time': 3087.46}, {u'name': u'engine-instantiate', u'time': 1482.5599999999995}, {u'name': u'first-frame', u'time': 4582.38}, {u'name': u'first-interactive', u'time': 4615.68}, {u'name': u'cpuTime', u'time': 4607.739999999999}]], [[{u'name': u'wasm-instantiate', u'time': 3061.88}, {u'name': u'engine-instantiate', u'time': 1291.92}, {u'name': u'first-frame', u'time': 4367.02}, {u'name': u'first-interactive', u'time': 4394.9800000000005}, {u'name': u'cpuTime', u'time': 4388.099999999999}]], [[{u'name': u'wasm-instantiate', u'time': 3043.94}, {u'name': u'engine-instantiate', u'time': 1305.6800000000003}, {u'name': u'first-frame', u'time': 4362.2}, {u'name': u'first-interactive', u'time': 4380.18}, {u'name': u'cpuTime', u'time': 4376.4800000000005}]]]}, u'browser_cycle': u'1', u'subtest_lower_is_better': True, u'cold': False, u'browser': u'Firefox 71.0a1 20191019095321', u'type': u'benchmark', u'page': u'http://localhost:35942/wasm-godot/index.html', u'unit': u'ms', u'alert_threshold': 2}
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - perftest-results-handler Info: received results in RaptorResultsHandler.add
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] Verifying results:"
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] [object Object]"
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] have 3 results for wasm-godot, as expected"
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] [object Object]"
[task 2019-10-19T11:49:47.124Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] closed tab 5"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] benchmark test finished"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] stopping gecko profiling"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] stopping gecko profiling"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] "
[task 2019-10-19T11:49:47.125Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.145Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] Removed tab: 5"
[task 2019-10-19T11:49:47.145Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] posting to control server"
[task 2019-10-19T11:49:47.145Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] Removed tab: 5"
[task 2019-10-19T11:49:47.146Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.147Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.152Z] 11:49:47 INFO - raptor-control-server Info: received webext_status: stopping gecko profiling
[task 2019-10-19T11:49:47.152Z] 11:49:47 INFO - raptor-control-server Info: received request to shutdown the browser
[task 2019-10-19T11:49:47.152Z] 11:49:47 INFO - raptor-control-server Info: received webext_status: Removed tab: 5
[task 2019-10-19T11:49:47.152Z] 11:49:47 INFO - raptor-control-server Info: shutting down browser (pid: 3724)
[task 2019-10-19T11:49:47.155Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.155Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:47.155Z] 11:49:47 INFO - PID 3724 | console.log: "[raptor-runnerjs] post success"
[task 2019-10-19T11:49:48.693Z] 11:49:48 INFO - Sat Oct 19 11:49:48 2019 MainThread Retrieving symbol zip from https://queue.taskcluster.net/v1/task/UqNdNboxSvu4tNQ71ntBiw/artifacts/public/build/target.crashreporter-symbols.zip...
[task 2019-10-19T11:49:48.693Z] 11:49:48 INFO - raptor-control-server Info: shutting down control server
[task 2019-10-19T11:49:49.154Z] 11:49:49 INFO - raptor-main Info: finished
[task 2019-10-19T11:49:49.154Z] 11:49:49 ERROR - Traceback (most recent call last):
[task 2019-10-19T11:49:49.155Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 1530, in <module>
[task 2019-10-19T11:49:49.155Z] 11:49:49 INFO - main()
[task 2019-10-19T11:49:49.155Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 1498, in main
[task 2019-10-19T11:49:49.155Z] 11:49:49 INFO - success = raptor.run_tests(raptor_test_list, raptor_test_names)
[task 2019-10-19T11:49:49.155Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 213, in run_tests
[task 2019-10-19T11:49:49.156Z] 11:49:49 INFO - self.run_test_teardown(test)
[task 2019-10-19T11:49:49.156Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 920, in run_test_teardown
[task 2019-10-19T11:49:49.156Z] 11:49:49 INFO - super(RaptorDesktop, self).run_test_teardown(test)
[task 2019-10-19T11:49:49.156Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 642, in run_test_teardown
[task 2019-10-19T11:49:49.156Z] 11:49:49 INFO - super(Raptor, self).run_test_teardown(test)
[task 2019-10-19T11:49:49.157Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/raptor.py", line 228, in run_test_teardown
[task 2019-10-19T11:49:49.157Z] 11:49:49 INFO - self.gecko_profiler.symbolicate()
[task 2019-10-19T11:49:49.157Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/gecko_profile.py", line 149, in symbolicate
[task 2019-10-19T11:49:49.157Z] 11:49:49 INFO - self.raptor_config['symbols_path']
[task 2019-10-19T11:49:49.157Z] 11:49:49 INFO - File "/home/cltbld/tasks/task_1571481093/build/tests/raptor/raptor/profiler/symbolication.py", line 149, in integrate_symbol_zip_from_url
[task 2019-10-19T11:49:49.158Z] 11:49:49 INFO - with zipfile.ZipFile(cStringIO.StringIO(io.read())) as zf:
[task 2019-10-19T11:49:49.158Z] 11:49:49 INFO - AttributeError: 'builtin_function_or_method' object has no attribute 'StringIO'
[task 2019-10-19T11:49:49.194Z] 11:49:49 ERROR - Return code: 1
[task 2019-10-19T11:49:49.195Z] 11:49:49 WARNING - setting return code to 1
[task 2019-10-19T11:49:49.195Z] 11:49:49 INFO - Copying Raptor results to upload dir:
[task 2019-10-19T11:49:49.195Z] 11:49:49 INFO - /home/cltbld/tasks/task_1571481093/build/blobber_upload_dir/perfherder-data.json
[task 2019-10-19T11:49:49.195Z] 11:49:49 INFO - Copying raptor results from /home/cltbld/tasks/task_1571481093/build/raptor.json to /home/cltbld/tasks/task_1571481093/build/blobber_upload_dir/perfherder-data.json
[task 2019-10-19T11:49:49.195Z] 11:49:49 CRITICAL - Error copying results /home/cltbld/tasks/task_1571481093/build/raptor.json to upload dir /home/cltbld/tasks/task_1571481093/build/blobber_upload_dir/perfherder-data.json
[task 2019-10-19T11:49:49.195Z] 11:49:49 INFO - [Errno 2] No such file or directory: u'/home/cltbld/tasks/task_1571481093/build/raptor.json'
[task 2019-10-19T11:49:49.196Z] 11:49:49 INFO - Running post-action listener: _package_coverage_data
[task 2019-10-19T11:49:49.197Z] 11:49:49 INFO - Running post-action listener: _resource_record_post_action
[task 2019-10-19T11:49:49.197Z] 11:49:49 INFO - Running post-action listener: process_java_coverage_data
[task 2019-10-19T11:49:49.197Z] 11:49:49 INFO - Running post-action listener: stop_device
[task 2019-10-19T11:49:49.197Z] 11:49:49 INFO - [mozharness: 2019-10-19 11:49:49.197344Z] Finished run-tests step (success)
[task 2019-10-19T11:49:49.197Z] 11:49:49 INFO - Running post-run listener: _resource_record_post_run
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - Total resource usage - Wall time: 63s; CPU: 21.0%; Read bytes: 58417152; Write bytes: 629039104; Read time: 464; Write time: 109156
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: CPU usage<br/>20.7%
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: I/O read bytes / time<br/>58,417,152 / 464
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: I/O write bytes / time<br/>629,039,104 / 109,156
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: CPU idle<br/>395.7 (79.0%)
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: CPU system<br/>8.9 (1.8%)
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: CPU user<br/>93.6 (18.7%)
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - TinderboxPrint: Swap in / out<br/>0 / 0
[task 2019-10-19T11:49:49.279Z] 11:49:49 INFO - install - Wall time: 8s; CPU: 13.0%; Read bytes: 0; Write bytes: 21008384; Read time: 0; Write time: 400
[task 2019-10-19T11:49:49.280Z] 11:49:49 INFO - run-tests - Wall time: 56s; CPU: 22.0%; Read bytes: 51716096; Write bytes: 608030720; Read time: 456; Write time: 108756
[task 2019-10-19T11:49:49.298Z] 11:49:49 WARNING - returning nonzero exit status 1
[taskcluster 2019-10-19T11:49:49.320Z] Exit Code: 1
[taskcluster 2019-10-19T11:49:49.320Z] User Time: 1m45.016s
[taskcluster 2019-10-19T11:49:49.320Z] Kernel Time: 8.32s
[taskcluster 2019-10-19T11:49:49.320Z] Wall Time: 1m39.48892879s
[taskcluster 2019-10-19T11:49:49.320Z] Result: FAILED
[taskcluster 2019-10-19T11:49:49.320Z] === Task Finished ===
[taskcluster 2019-10-19T11:49:49.320Z] Task Duration: 1m39.490031015s
[taskcluster 2019-10-19T11:49:49.920Z] Uploading artifact public/logs/localconfig.json from file logs/localconfig.json with content encoding "gzip", mime type "application/json" and expiry 2020-10-18T09:58:01.457Z
[taskcluster 2019-10-19T11:49:50.602Z] Uploading artifact public/test_info/resource-usage.json from file build/blobber_upload_dir/resource-usage.json with content encoding "gzip", mime type "application/json" and expiry 2020-10-18T09:58:01.457Z
[taskcluster:error] exit status 1

Flags: needinfo?(rwood)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla71 → ---

Ah, the Py3 support change in symbolication.py broke gecko profiling. Updating.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=95b18d15e58088cde569bd1f2ec5352fb3990d85

Flags: needinfo?(rwood)
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef22242bd819
Raptor python unit tests: add support for python 3 r=ahal
Status: REOPENED → RESOLVED
Closed: 26 days ago23 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
You need to log in before you can comment on or make changes to this bug.