Closed Bug 1520458 Opened 2 years ago Closed 20 days ago

Update Raptor to run on python 3

Categories

(Testing :: Raptor, enhancement, P2)

Version 3
enhancement

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: Bebe, Assigned: Bebe)

References

Details

Attachments

(3 files, 3 obsolete files)

Update Raptor and make it python 3 compatible

Depends on: 1520463
Priority: -- → P2

Note: This will be dependent upon the Raptor dependencies (i.e. mozharness/mozbase) being Python 3 compatible which I believe they are not (yet). So we may be somewhat limited what we can do here; but we can at least make sure the native Raptor code is python 3 ready.

Blocks: 1582756
See Also: → mozbase-py3
Assignee: nobody → rwood
Status: NEW → ASSIGNED
Priority: P2 → P1
Depends on: 1428705
Priority: P1 → P2
No longer blocks: 1582756
Assignee: rwood → nobody
Status: ASSIGNED → NEW
Assignee: nobody → fstrugariu
Status: NEW → ASSIGNED
Priority: P2 → P1
Assignee: fstrugariu → nobody
Status: ASSIGNED → NEW
Priority: P1 → P2
Assignee: nobody → fstrugariu
Status: NEW → ASSIGNED
Attachment #9123501 - Attachment is obsolete: true
Assignee: fstrugariu → nobody
Status: ASSIGNED → NEW
No longer blocks: 1601296
Blocks: mach-py3
Duplicate of this bug: 1638979
Duplicate of this bug: 1638980
Assignee: nobody → fstrugariu
Status: NEW → ASSIGNED
Pushed by fstrugariu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76bffd1b3c6e
Update Raptor to run on python 3 r=perftest-reviewers,davehunt
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79

mach raptor is still in the list of Python 2 commands; it should be deleted before this bug is closed. Same with raptor-test I think.

Status: RESOLVED → REOPENED
Flags: needinfo?(fstrugariu)
Resolution: FIXED → ---

@Ricky see the comment in the bug. Even if we remove mach raptor is still in the list of Python 2 commands mozharness still setups and uses python2 to run the test. Not sure how to proceed in this case as I don't have experience with mozharness

Flags: needinfo?(fstrugariu) → needinfo?(rstewart)

Commented on the patch.

Flags: needinfo?(rstewart)
Attachment #9182317 - Attachment description: Bug 1520458 - Remove raptor from Pthon 2 mach commands → Bug 1520458 - Remove raptor from Python 2 mach commands

Depends on D93936

This is blocked by bug 1532427
because of mozharness we can't run python3 in raptor. I can hack it locally but it needs more work on that part

Depends on: 1532427

Dave I have 2 patches open on this task. one r+ and one under review but blocked by the above bug and suggestions on how to continue with this?

Flags: needinfo?(dave.hunt)

(In reply to Florin Strugariu [:Bebe] (needinfo me) from comment #14)

Dave I have 2 patches open on this task. one r+ and one under review but blocked by the above bug and suggestions on how to continue with this?

We'd either need to resolve bug 1532427 or find a workaround. I'm not sure on the priority of updating mozharness to support Python 3, perhaps Mihai could comment on that?

Flags: needinfo?(dave.hunt) → needinfo?(mtabara)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚GMT from comment #15)

(In reply to Florin Strugariu [:Bebe] (needinfo me) from comment #14)

Dave I have 2 patches open on this task. one r+ and one under review but blocked by the above bug and suggestions on how to continue with this?

We'd either need to resolve bug 1532427 or find a workaround. I'm not sure on the priority of updating mozharness to support Python 3, perhaps Mihai could comment on that?

More to come in the next weeks once we clarify the roadmap for Q1/H1. I'll let the NI until then to circle back to comment on it.

Attachment #9182317 - Attachment is obsolete: true

run raptor in CI with python-3

Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/650339286f35
run raptor with python-3 r=ahal,perftest-reviewers
Flags: needinfo?(mtabara)
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/20db6507d9f4
Run ./mach raptor with Python 3, r=perftest-reviewers,Bebe,sparky
Status: REOPENED → RESOLVED
Closed: 10 months ago20 days ago
Keywords: leave-open
Resolution: --- → FIXED
Attachment #9185693 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.