Update Chromium version running with Raptor in production

RESOLVED FIXED in Firefox 67

Status

enhancement
P1
normal
RESOLVED FIXED
6 months ago
5 months ago

People

(Reporter: rwood, Assigned: rwood)

Tracking

Version 3
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Currently the Chromium version used with Raptor in production is hard-coded (until the Chromium build/fetch task is landed Bug 1476372). In the mean time we should update the Chromium revision.

(In reply to Robert Wood [:rwood] from comment #3)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=97b864a2749e237d1a2fc3974ae4dc005c3e2111

Ah, Chrome changed their URL and filename for getting the latest chromium build; it is now /Win_64/<latest_rev>/chrome-win.zip instead of separate Win_x32 and Win_x64.

Blocks: 1495903

(In reply to Robert Wood [:rwood] from comment #7)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=a78c4057d2705e8b88d8be99b6d9970781a446c7

The new versions of Chromium work fine on Win and Linux but on OSX the pageload tests fail. I downloaded the same version of Chromium on my local OSX and reproduced the issue. During pageload with the newer Chromium builds, an OSX popup is appearing which is causes the pages to not load and Raptor to timeout.

Popup says: "Chromium wants to use your confidential information stored in 'Chromium Safe Storage' in your keychain. The authenticity of 'Chromium' cannot be verified.." The pop-up has a password field, and buttons for 'Always Alolow', 'Deny', and 'Allow'.

I'll see if there's any way to turn this off...

I haven't figured out yet how to turn off that dialog on OSX. For now I suggest we update to the new Chromium versions for Linux x64 and Win7/10 since that version works, but leave OSX on the older version for now. I'll leave this bug open for figuring out how to fix the issue on OSX.

Keywords: leave-open
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9e1039ecab0
Update Chromium version running with Raptor in production; r=davehunt
https://hg.mozilla.org/projects/cedar/rev/d9e1039ecab03119610f4dea535eff9d9a51c901
Bug 1520523 - Update Chromium version running with Raptor in production; r=davehunt

Here is a screenshot (from my local OSX) of what is causing the issue on Raptor page-load with the newer Chromium builds. Problem is on OSX only.

The Raptor page-load tab URL stays at "about:blank" - when Raptor tries to update it to the test page, the OSX keychain dialog pops up - and the page is never loaded. If I click the "Deny" button the pop-up dialog, then the tab URL is updated and the page is loaded just fine and Raptor finishes successfully.

I have no idea why, when I push to try, the try link added is wrong/doesn't work. Here's the latest correct link:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=97f9709c1e7e77aa33e85cd5e3fa5beb9b106917

(In reply to Robert Wood [:rwood] from comment #26)

I have no idea why, when I push to try, the try link added is wrong/doesn't work. Here's the latest correct link:

It was an issue with the bzpost hg plugin which I just disabled.

So looks like the key chain dialog on OSX no longer pops up by using the --use-mock-keychain chromium arg (thanks :davehunt) however now seeing timeouts on some pages with newer Chromium on OSX (however it works fine locally). Try push with some increased page timeouts:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b75370ffea32d7426bb2970a2c239cbc3d65c8df

Attachment #9045722 - Attachment is obsolete: true

(In reply to Robert Wood [:rwood] from comment #30)

Trying out the very latest again:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cb726c57ad8f6ff07ea6386696311fee0fef4444

Excellent this latest version of Chromium is looking really good, just one timeout (imgur) on OSX; I'll increase the timeout and try that one again.

Latest Chromium fails to load the imgur test page; going ahead and landing this update (as we need the -mock-keychain fix) but temporarily disabling tp6-imgur-chrome. Filed follow-up Bug 1529918.

Keywords: leave-open
Pushed by rwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b892c1e3909f
Update Raptor Chromium rev; r=davehunt
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.