Closed Bug 1520568 Opened 2 years ago Closed 2 years ago

Add 1/3 and 2/3 layouts for CardGrid component

Categories

(Firefox :: New Tab Page, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 66
Iteration:
66.3 - Jan 7 - 20
Tracking Status
firefox66 --- fixed

People

(Reporter: gsuntop, Assigned: gsuntop)

References

Details

(Keywords: github-merged)

Attachments

(1 file)

No description provided.
Assignee: nobody → gsuntop
Blocks: 1520691
Keywords: github-merged
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66

Hi,

Any updates on QA steps?

Flags: needinfo?(gsuntop)
Summary: Refine CardGrid component for Activity Stream → Add 1/3 and 2/3 layouts for CardGrid component
Duplicate of this bug: 1521576

QA Steps

  • set browser.newtabpage.activity-stream.discoverystream.config to {"enabled":true,"layout_endpoint":"https://gist.githubusercontent.com/gvn/76af39c92085c247dd5dd7ccc2412618/raw/cc3ea88fe7c95e7b1ba8d4341fd21555004cc434/disco.json"}
  • compare 1/3 and 2/3 layouts for CardGrid component to those in the Figma
Flags: needinfo?(gsuntop)

QA Note :

Widths exceed by some px for the 2/3rd card and also looks intentional..not matching the mock.

  • Like for 2/3rd card grid, requirement is 592px(per mock) but the latest FF Nightly build has 608px.

  • Card borders donot have shadow (grey) per mock but the build has it.

  • Depends on bug 1522726.

Here is the recording : https://www.dropbox.com/home?preview=bug+-+1520568+question.mp4

Flags: needinfo?(gsuntop)

Per discussion with Wolasi: It's ok to leave the build as-is:

ds-column-8: 608px + gridColumnGap: 48px + ds-column-4: 280px = 936px

The mock has different numbers for widths, but that's safe to ignore for now.

Flags: needinfo?(gsuntop)
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.