Closed Bug 1520641 Opened 2 years ago Closed 2 months ago

Make zoom level percentage bubble animation obey prefers-reduced-motion

Categories

(Firefox :: Theme, defect, P3)

64 Branch
defect
Points:
1

Tracking

()

RESOLVED FIXED
Firefox 78
Iteration:
78.2 - May 18 - May 31
Tracking Status
firefox78 --- fixed

People

(Reporter: yetoohappy, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

  1. Set toolkit.cosmeticAnimations.enabled to false.
  2. Ctrl + Scroll fast enough or have lag on the system to cause the percentage bubble to think that there was a long enough pause between the last scroll and the next to do the expand animation. (I'm probably getting what causes that animation wrong and the sporadic behaviour of it in itself should be reported as another bug)

Actual results:

The animation which makes the percentage bubble to grow and shrink in half a second or so isn't disabled.

Expected results:

The animation should have been disabled due to toolkit.cosmeticAnimations.enabled being set to false.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
20190115103851

:Dolske since you fixed bug 1295769 maybe you're interested in this.

Blocks: 565718
Status: UNCONFIRMED → NEW
Component: Untriaged → Theme
Ever confirmed: true
Flags: needinfo?(dolske)
OS: Unspecified → All
Hardware: Unspecified → All

Note that this pref is somewhat badly named, and it's not quite clear to me that we should in fact honor it here. See the discussion in bug 1478597 for details.

Priority: -- → P5
See Also: → 1478597
Flags: needinfo?(dolske)
Blocks: 1478597
Type: defect → enhancement
Priority: P5 → P3
See Also: 1478597
Summary: Zoom level percentage bubble animation isn't disabled by toolkit.cosmeticAnimations.enabled when set to false. → Make zoom level percentage bubble animation obey prefers-reduced-motion
Keywords: access
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Points: --- → 1
Type: enhancement → defect
Iteration: --- → 78.2 - May 18 - May 31
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7194adf4f757
Make zoom level percentage bubble animation obey prefers-reduced-motion. r=jaws
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
QA Whiteboard: [qa-78b-p2]
You need to log in before you can comment on or make changes to this bug.