Closed Bug 1520842 Opened 1 year ago Closed 3 months ago

Change tests to deal with cross-origin windows being in a separate process

Categories

(Core :: DOM: Core & HTML, enhancement, P2)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1561972
Tracking Status
firefox66 --- affected

People

(Reporter: peterv, Unassigned)

References

(Blocks 1 open bug)

Details

This will mostly be changing tests that rely on SpecialPowers.wrap on a cross-origin window to get to properties that are not available cross-origin.

I have a patch that turns on the remote DOM proxies, even though we don't have per-origin processes. I'll post a link to a try push with that patch applied, it should give us some idea of the amount of tests that need fixing.

Priority: -- → P2

Here's my latest push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f8197c0fbfd3cbcaf58e1a5ebe7409c425fed939

Some categories of test failures:

  • Using SpecialPowers to use same-origin-only properties on cross-origin windows
  • Using CanvasRenderingContext2D.drawWindow on cross-origin windows
  • Relying on certain operations that used to be mostly synchronous but are now asynchronous (window.focus for example)

I suspect that we can fix a lot of the CanvasRenderingContext2D.drawWindow ones by using a different origin, so that the windows is still cross-origin but same-site (so it'll eventually remain same-process). The tests that rely on synchronous operations might need to be broken up in pieces and use callbacks.

Component: DOM → DOM: Core & HTML
No longer blocks: oop-frames

Kris, the pointers here by peterv might help with the fission mode test failures you're looking into.

Flags: needinfo?(kmaglione+bmo)
Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: fission-mochitests
You need to log in before you can comment on or make changes to this bug.