Closed Bug 1429896 (oop-frames) Opened 2 years ago Closed 7 months ago

[meta] implement a minimal form of navigable out-of-process iframes

Categories

(Core :: DOM: Content Processes, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Fission Milestone M2

People

(Reporter: Nika, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: meta)

Attachments

(1 obsolete file)

I thought we already had a bug for this, but I couldn't find it, so I figured I'd file one.
Attached patch WIP Basic OOP iframe setup (obsolete) — Splinter Review
For anyone who is going to be working with oop iframes, this is a quick hack to get an iframe with the moz-force-remote attribute to render in a remote process. It's all behind 2 prefs: dom.ipc.tabs.nested.enabled and dom.ipc.oopif.force.enabled.

MozReview-Commit-ID: 4JiLFX8JEzm
Summary: Out of Process iframes → [meta] Out of Process iframes
Assignee: nobody → kyle
Summary: [meta] Out of Process iframes → [meta] Out of Process (OOP) iframes
Task #1: Take patch in this bug, compile into nightly, punch self in face with resulting browser until enough bugs are found and logged to give us a good idea on the lowest hanging and farthest reaching fruit to start on.
Priority: -- → P1
Priority: P1 → P2
Alias: oop-frames
Trying to pare down the rather silly results from Comment 3. This is a slightly more readable try run, this time: 

- Not spawning OOP iframes for pages with system principals
- Not spawning OOP iframes when not in e10s mode

https://treeherder.mozilla.org/#/jobs?repo=try&revision=01d8523e7943ba4a026fef3e2e1e39df062407b8
Blocks: 1443253
Assignee: kyle → nobody
Summary: [meta] Out of Process (OOP) iframes → [meta] Implement a minimal form of out-of-process iframes using cross process window proxies and abstract browsing context trees
Depends on: graphics-fission
No longer blocks: 1443253
Duplicate of this bug: 1443253
Depends on: 1510760
Depends on: 1519151
Depends on: 1467216
Depends on: 1490803
Depends on: 1520842
Depends on: 1522713
Fission Milestone: --- → M2
Duplicate of this bug: nested-oop
Depends on: fission-events
Summary: [meta] Implement a minimal form of out-of-process iframes using cross process window proxies and abstract browsing context trees → [meta] implement a minimal form of navigable out-of-process iframes
Depends on: 1527960
Depends on: 1529237
Depends on: 845693
Depends on: 1530656
Depends on: 1530661
No longer depends on: 1530656
No longer depends on: 961689
No longer depends on: 1419857
No longer depends on: 845693
No longer depends on: 1440212
No longer depends on: 1535390
Attachment #8949540 - Attachment is obsolete: true
No longer depends on: 1516343
No longer depends on: 1440537
No longer depends on: fission-events
No longer depends on: 1440754
No longer depends on: 1443677
No longer depends on: 1443683
No longer depends on: 1490803
Depends on: 1500257
No longer depends on: graphics-fission
No longer depends on: 1451455
No longer depends on: 1443687
No longer depends on: 1520842
No longer depends on: 1451429
No longer depends on: rm-docshell-tree-item
No longer depends on: 1467216
No longer depends on: 1510760
Depends on: 1541038
Depends on: 1542696
Whiteboard: [4/11] blocked on last crash bug 1541038
Whiteboard: [4/11] blocked on last crash bug 1541038 → [4/11] last crash bug 1541038 remaining
No longer depends on: 1541038
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Whiteboard: [4/11] last crash bug 1541038 remaining
Blocks: 1443253
No longer blocks: 1443253
Depends on: 1443253
Blocks: 1443253
No longer depends on: 1443253
You need to log in before you can comment on or make changes to this bug.