`mach bootstrap` invokes `mach configure` without a valid mozconfig when targeting Android

RESOLVED FIXED in Firefox 67

Status

enhancement
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: nalexander, Assigned: andi)

Tracking

Trunk
mozilla67
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment)

While working on Bug 1477487, I noticed that mach bootstrap invokes mach configure:

https://searchfox.org/mozilla-central/rev/dac799c9f4e9f5f05c1071cba94f2522aa31f7eb/python/mozbuild/mozbuild/mach_commands.py#2510

For Android targets, that makes no sense: we suggest a mozconfig but we don't create one; that makes mach configure fail immediately (or configure Desktop, which is even weirder).

I have no idea what is intended here, but it's clearly broken for Android targets.

Andi: you landed this feature in Bug 1328454. Can you explain what you were trying to achieve, and suggest how we can make this less obnoxious for Android targets?

Depends on: 1328454
Flags: needinfo?(bpostelnicu)
Assignee

Updated

5 months ago
Assignee: nobody → bpostelnicu
Flags: needinfo?(bpostelnicu)
Assignee

Comment 2

5 months ago

Yes, I've tried a shortcut when implementing that, the patch will fix this by only downloading the artifact without configuring the tree.

Attachment #9037539 - Attachment description: Bug 1520920 - do not 'mach configure' when downloading clang-tidy artifact. r?nalexander → Bug 1520920 - do not 'mach configure' when downloading clang-tidy artifact. r=nalexander

Comment 4

4 months ago
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d6bda0108d61
do not 'mach configure' when downloading clang-tidy artifact. r=nalexander

Comment 6

4 months ago
Pushed by bpostelnicu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ad69518248d
do not 'mach configure' when downloading clang-tidy artifact. r=nalexander
Assignee

Comment 7

4 months ago

This was because a fail in the rebase.

Flags: needinfo?(bpostelnicu)

Comment 8

4 months ago
bugherder
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1527266
You need to log in before you can comment on or make changes to this bug.