Closed Bug 1521186 Opened 11 months ago Closed 9 months ago

Make mach bootstrap download a nasm toolchain file

Categories

(Firefox Build System :: Toolchains, enhancement)

x86_64
All
enhancement
Not set

Tracking

(firefox67 fixed)

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: TD-Linux, Assigned: TD-Linux)

References

Details

Attachments

(1 file)

No description provided.

Changing title as we can do this on Windows too.

OS: Linux → All
Summary: Make mach bootstrap download a nasm toolchain file on Linux → Make mach bootstrap download a nasm toolchain file

Meanwhile I got this on Windows:

ERROR: nasm 2.13 or greater is required for AV1 support. Either install nasm or add --disable-av1 to your configure options.

So what is the process for "install nasm". The cbindgen message is more helpful: cargo install cbindgen --force.

For now you can do ./mach artifact toolchain --from-build win64-nasm which will download it from taskcluster and unpack it into your current dir. Then I guess you need to put it on your $PATH (I tried moving it to ~/.mozbuild/nasm/nasm.exe but it didn't get auto-detected there).

And "edited" comment on BMO, wow, that's new (although I don't see a diff). More to the point: That's a little complicated, so maybe for now we just set the option if we don't need nasm.

I guess you need to put it on your $PATH (I tried moving it to
~/.mozbuild/nasm/nasm.exe but it didn't get auto-detected there).

https://searchfox.org/mozilla-central/rev/23fb3d3791eb9155fb31e76d322d6812cffded90/build/moz.configure/toolchain.configure#96
sounds like it requires you to set NASM in your environment or mozconfig, we should do a better job of picking one up from .mozbuild if it exists.

The attached patch does exactly that.

Pushed by tdaede@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de512e13803b
Download nasm toolchain on Windows and Linux. r=firefox-build-system-reviewers,mshal
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Duplicate of this bug: 1534613
Duplicate of this bug: 1508168
You need to log in before you can comment on or make changes to this bug.