Closed Bug 1521305 Opened 3 years ago Closed 3 years ago

firefox is freezing on a website

Categories

(Firefox :: General, defect)

Desktop
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1519463
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- fix-optional
firefox66 --- affected

People

(Reporter: Muhammad.Fayed, Unassigned)

References

Details

(Keywords: hang, memory-footprint, Whiteboard: [fxperf])

Attachments

(1 file)

Attached image issue.png

Hello,

I've been using Firefox since version 1 and hooked up on all versions ever since, celebrated breaking Guinness record in 2008 and I always wanted to say this... I really miss Version 3 :(

Anyway, the new versions of firefox are aweasome but it is freezing on a streaming media website while every other browser can handle it smoothly.

I think the freezing started to happen with all 50+ versions

The website is [http://seehd.pl/] like in [http://www.seehd.pl/bumblebee-watch-online/]

Thanks..

I can repro hang, Giga memory usage on Firefox65.0b11 Windows10 64bit.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Not interesting for evil traps (the browser still works), but might be worth for someone to take a profile of this.

Flags: needinfo?(florian)
Whiteboard: [fxperf]

Could you please point us to a performance profile taken through http://perf-html.io/ ?

Flags: needinfo?(Muhammad.Fayed)

When profiling, >90% of the time is spent in a script at https://c.adsco.re/ calling window.matchMedia.

Emilio, is there anything to improve from this profile? https://perfht.ml/2FDRCU4

Here are 2 other profiles where the compositor thread of the parent process is very busy: https://perfht.ml/2FHkfzJ https://perfht.ml/2FDSDLS

Flags: needinfo?(florian) → needinfo?(emilio)

This is a tracking script being stupid, see bug 1519463. I'm trying to find time to fix this in bug 1490401.

Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1490401
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
Duplicate of bug: 1519463
Flags: needinfo?(Muhammad.Fayed)
You need to log in before you can comment on or make changes to this bug.