MediaQueryList::Matches shouldn't need a pres context, but a document instead | matchMedia should work in display:none iframes

RESOLVED FIXED in Firefox 68

Status

()

defect
P3
normal
RESOLVED FIXED
10 months ago
2 months ago

People

(Reporter: emilio, Assigned: emilio)

Tracking

(Blocks 1 bug)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: [webcompat][wptsync upstream])

Attachments

(1 attachment)

Assignee

Description

10 months ago
No description provided.
Priority: -- → P3
Assignee

Updated

6 months ago
Depends on: 1519496
Assignee

Updated

5 months ago
Blocks: 1519463

This is a webcompat issue that causes some tracking scripts to fall into infinite loops, see bug 1519463.

Summary: MediaQueryList::Matches shouldn't need a pres context, but a document instead. → MediaQueryList::Matches shouldn't need a pres context, but a document instead | matchMedia should work in display:none iframes
Whiteboard: [webcompat]
Assignee

Comment 2

5 months ago

I guess I should just fix it. I did most of the work in bug 1430608, and the plumbing is pretty annoying but nothing egregious.

Assignee: nobody → emilio
Flags: needinfo?(emilio)
Assignee

Comment 3

5 months ago

Ah, this is not as easy, I know why... We need a default style to evaluate media queries. And a style right now requires a pres context.

Assignee

Updated

5 months ago
Depends on: 1430623
Assignee

Updated

5 months ago
Depends on: 1521137
Assignee

Updated

5 months ago
Duplicate of this bug: 1519496
Assignee

Updated

5 months ago
Blocks: 1521305
Assignee

Updated

5 months ago
Depends on: 1521863
Assignee

Updated

5 months ago
Depends on: 1524328
Assignee

Updated

5 months ago
Depends on: 1525134
Assignee

Updated

5 months ago
Depends on: 1525371
Assignee

Updated

5 months ago
Depends on: 1526294
Assignee

Updated

4 months ago
Depends on: 1528712
Assignee

Updated

4 months ago
Depends on: 1528914
Assignee

Updated

4 months ago
Depends on: 1530193
Assignee

Updated

4 months ago
Depends on: 1530751
Assignee

Updated

3 months ago
Depends on: 1535788
Assignee

Updated

3 months ago
Depends on: 1536176
Assignee

Comment 5

3 months ago

Finally!

Flags: needinfo?(emilio)

Comment 7

3 months ago
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f98617ff7cf5
MatchMedia should work inside display: none iframes. r=heycam

Comment 8

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee

Updated

3 months ago
Duplicate of this bug: 1519463
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16488 for changes under testing/web-platform/tests
Whiteboard: [webcompat] → [webcompat][wptsync upstream]
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.